# CVE-2025-8555: atjiu pybbs search cross site scripting

> Remote attackers can inject malicious scripts via the search keyword parameter in pybbs, potentially leading to session hijacking or code execution.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 5 Aug 2025
- **Updated:** 5 Aug 2025
- **Also known as:** GHSA-4h69-cjx4-hx8h

## What is CVE-2025-8555?

CVE-2025-8555 is a medium-severity cross-site scripting vulnerability in atjiu pybbs, published on 5 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, was found in atjiu pybbs up to 6.0.0. Affected is an unknown function of the file /search. The manipulation of the argument keyword leads to cross site scripting. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. The name of the patch is 2fe4a51afbce0068c291bc1818bbc8f7f3b01a22. It is recommended to apply a patch to fix this issue.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-8555?

It affects 1 product.


Products: Pybbs Project Pybbs.

## How do I fix CVE-2025-8555?

No fix has been published for CVE-2025-8555 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-8555 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8555 exists.

## Other vulnerabilities in atjiu pybbs

- [CVE-2020-28702](https://insights.sbomify.com/CVE-2020-28702/): SQL injection in n/a (high 7.5)
- [CVE-2025-8546](https://insights.sbomify.com/CVE-2025-8546/): atjiu pybbs Verification Code login Captcha (medium 6.9)
- [CVE-2025-8547](https://insights.sbomify.com/CVE-2025-8547/): atjiu pybbs Email Verification improper authorization (medium 6.9)
- [CVE-2025-8548](https://insights.sbomify.com/CVE-2025-8548/): atjiu pybbs Registered Email SettingsApiController.java sendEmailCode information exposure (medium 6.3)
- [CVE-2025-8549](https://insights.sbomify.com/CVE-2025-8549/): atjiu pybbs UserAdminController.java update weak password (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8555 and fix it if it is affected.

What it is: CVE-2025-8555 is a medium-severity cross-site scripting vulnerability in atjiu pybbs, published on 5 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8555 exists.

Affected product: atjiu pybbs. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8555/ (Markdown: https://insights.sbomify.com/CVE-2025-8555/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8555
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8555
- OSV: https://osv.dev/vulnerability/CVE-2025-8555

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8555/
Summaries are generated and may contain mistakes; the official description above is the record.
