# CVE-2025-8671: CVE-2025-8671

> Attackers can cause denial of service by exploiting HTTP/2 stream reset mismatches to force excessive server resource consumption.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Aug 2025
- **Updated:** 4 Nov 2025
- **Also known as:** ALPINE-CVE-2025-8671, CLEANSTART-2026-FY47942, CLEANSTART-2026-YS82863, DEBIAN-CVE-2025-8671, GHSA-mrjm-qq9m-9mjq, MGASA-2025-0239, OESA-2025-2166, OESA-2025-2167, OESA-2025-2185, OESA-2025-2186, OESA-2025-2187, OESA-2025-2188, OESA-2025-2189, OESA-2025-2238, OESA-2025-2253, OESA-2025-2464, OESA-2026-1423, RUSTSEC-2025-0070, UBUNTU-CVE-2025-8671, openSUSE-SU-2025:15448-1, openSUSE-SU-2026:10219-1

## What is CVE-2025-8671?

CVE-2025-8671 is a high-severity denial of service vulnerability in Fastly Enterprise Desktop, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A mismatch caused by client-triggered server-sent stream resets between HTTP/2 specifications and the internal architectures of some HTTP/2 implementations may result in excessive server resource consumption leading to denial-of-service (DoS).  By opening streams and then rapidly triggering the server to reset them—using malformed frames or flow control errors—an attacker can exploit incorrect stream accounting. Streams reset by the server are considered closed at the protocol level, even though backend processing continues. This allows a client to cause the server to handle an unbounded number of concurrent streams on a single connection. This CVE will be updated as affected product details are released.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2025-8671?

1 open source package ship an affected version, including pingora-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pingora-core` | crates.io | From 0.0.0-0 | 0.6.0 |
| `dnsdist` | openSUSE:Tumbleweed | All versions | 2.0.2-1.1 |
| `lighttpd` | openSUSE:Tumbleweed | All versions | 1.4.80-1.1 |

## How do I fix CVE-2025-8671?

Upgrade pingora-core to 0.6.0 or later.

## Is CVE-2025-8671 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8671 exists.

Public exploit code:

- CVE-2025-25063 MadeYouReset HTTP/2 DDoS (github_poc): https://github.com/moften/CVE-2025-8671-MadeYouReset-HTTP-2-DDoS
- A Python script that checks if a web server is vulnerable to MadeYouReset (CVE-2025-8671) — an HTTP/2 DoS attack that bypasses Rapid Reset mitigations by tricking the server into resetting its own streams. It probes the target by sending a malformed WINDOW_UPDATE frame and inspects whether the server responds. (github_poc): https://github.com/ayushghatkar8080/MadeYouReset_Tester
- PoC para validar vulnerabilidade MadeYouReset (github_poc): https://github.com/mateusm1403/PoC-CVE-2025-8671-MadeYouReset-HTTP-2
- PoC éducatif pour la vulnérabilité CVE-2025-8671 (DoS HTTP/2 sur lighttpd). À utiliser uniquement en laboratoire local. (github_poc): https://github.com/abiyeenzo/CVE-2025-8671
- CVE-2025-8671 vulnerability POC  (github_poc): https://github.com/mysara2022/CVE-2025-8671-vulnerability-POC-

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8671 and fix it if it is affected.

What it is: CVE-2025-8671 is a high-severity denial of service vulnerability in Fastly Enterprise Desktop, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8671 exists.

Affected packages and fixed versions:
- pingora-core (crates.io): affected from 0.0.0-0; fixed in 0.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8671/ (Markdown: https://insights.sbomify.com/CVE-2025-8671/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8671
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8671
- OSV: https://osv.dev/vulnerability/CVE-2025-8671

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8671/
Summaries are generated and may contain mistakes; the official description above is the record.
