CVE-2025-8678 WP Crontrol - 1.17.0 - 1.19.1 - Authenticated (Administrator+) Blind Server-Side Request Forgery
Administrators can exploit blind SSRF in WP Crontrol to query and modify internal services via arbitrary web requests.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-8678?
CVE-2025-8678 is a medium-severity server-side request forgery vulnerability in johnbillion WP Crontrol, published on 22 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
The WP Crontrol plugin for WordPress is vulnerable to blind Server-Side Request Forgery in versions 1.17.0 to 1.19.1 via the 'wp_remote_request' function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
Weakness: CWE-918
Which versions are affected by CVE-2025-8678?
2 open source packages ship an affected version, including johnbillion/wp-crontrol.
| Package | Affected | Fixed in |
|---|---|---|
johnbillion/wp-crontrol Packagist | From 1.17.0 | 1.19.2 |
johnbillion/wp-crontrol Packagist | From 1.17.0 | 1.19.2 |
How do I fix CVE-2025-8678?
Upgrade johnbillion/wp-crontrol to 1.19.2 or later.
Upgrade, and send outbound requests through an allow-list that blocks internal addresses. More about Server-side request forgery.
Is CVE-2025-8678 being exploited?
There is no known exploitation of CVE-2025-8678 in the wild and no public exploit code.
Sources
Also known as GHSA-35c5-67fm-cpcp.