{"answers":{"affected":"2 open source packages ship an affected version, including johnbillion/wp-crontrol.","exploited":"There is no known exploitation of CVE-2025-8678 in the wild and no public exploit code.","fix":"Upgrade johnbillion/wp-crontrol to 1.19.2 or later.","what":"CVE-2025-8678 is a medium-severity server-side request forgery vulnerability in johnbillion WP Crontrol, published on 22 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-8678 and fix it if it is affected.\n\nWhat it is: CVE-2025-8678 is a medium-severity server-side request forgery vulnerability in johnbillion WP Crontrol, published on 22 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-8678 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- johnbillion/wp-crontrol (Packagist): affected from 1.17.0; fixed in 1.19.2\n- johnbillion/wp-crontrol (Packagist): affected from 1.17.0; fixed in 1.19.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-8678/ (Markdown: https://insights.sbomify.com/CVE-2025-8678/index.md)","id":"CVE-2025-8678","markdown":"https://insights.sbomify.com/CVE-2025-8678/index.md","name":"CVE-2025-8678","record":{"aliases":["GHSA-35c5-67fm-cpcp"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"high_privilege","summary":"Administrators can exploit blind SSRF in WP Crontrol to query and modify internal services via arbitrary web requests.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"The WP Crontrol plugin for WordPress is vulnerable to blind Server-Side Request Forgery in versions 1.17.0 to 1.19.1 via the 'wp_remote_request' function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WP Crontrol - 1.17.0 - 1.19.1 - Authenticated (Administrator+) Blind Server-Side Request Forgery","id":"CVE-2025-8678","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"ssrf","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"ExtremeGuest Essentials Captive Portal Unauthenticated Brute Force","id":"CVE-2025-8679"},"packages":[{"ecosystem":"Packagist","fixed":["1.19.2"],"introduced":["1.17.0"],"last_affected":[],"package":"johnbillion/wp-crontrol","purl":null,"source":"GHSA-35c5-67fm-cpcp"},{"ecosystem":"Packagist","fixed":["1.19.2"],"introduced":["1.17.0"],"last_affected":[],"package":"johnbillion/wp-crontrol","purl":"pkg:composer/johnbillion/wp-crontrol","source":"GHSA-35c5-67fm-cpcp"}],"prev":{"headline":"Resource exhaustion via malformed DNSKEY handling","id":"CVE-2025-8677"},"products":["WP Crontrol"],"published":"2025-08-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-08-25","vendors":["johnbillion"]},"summary":"Administrators can exploit blind SSRF in WP Crontrol to query and modify internal services via arbitrary web requests.","url":"https://insights.sbomify.com/CVE-2025-8678/"}