# CVE-2025-8678: WP Crontrol - 1.17.0 - 1.19.1 - Authenticated (Administrator+) Blind Server-Side Request Forgery

> Administrators can exploit blind SSRF in WP Crontrol to query and modify internal services via arbitrary web requests.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Aug 2025
- **Updated:** 25 Aug 2025
- **Also known as:** GHSA-35c5-67fm-cpcp

## What is CVE-2025-8678?

CVE-2025-8678 is a medium-severity server-side request forgery vulnerability in johnbillion WP Crontrol, published on 22 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

The WP Crontrol plugin for WordPress is vulnerable to blind Server-Side Request Forgery in versions 1.17.0 to 1.19.1 via the 'wp_remote_request' function. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-8678?

2 open source packages ship an affected version, including johnbillion/wp-crontrol.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `johnbillion/wp-crontrol` | Packagist | From 1.17.0 | 1.19.2 |
| `johnbillion/wp-crontrol` | Packagist | From 1.17.0 | 1.19.2 |

## How do I fix CVE-2025-8678?

Upgrade johnbillion/wp-crontrol to 1.19.2 or later.

## Is CVE-2025-8678 being exploited?

There is no known exploitation of CVE-2025-8678 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8678 and fix it if it is affected.

What it is: CVE-2025-8678 is a medium-severity server-side request forgery vulnerability in johnbillion WP Crontrol, published on 22 Aug 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-8678 in the wild and no public exploit code.

Affected packages and fixed versions:
- johnbillion/wp-crontrol (Packagist): affected from 1.17.0; fixed in 1.19.2
- johnbillion/wp-crontrol (Packagist): affected from 1.17.0; fixed in 1.19.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8678/ (Markdown: https://insights.sbomify.com/CVE-2025-8678/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8678
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8678
- OSV: https://osv.dev/vulnerability/CVE-2025-8678

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8678/
Summaries are generated and may contain mistakes; the official description above is the record.
