# CVE-2025-8709: SQL Injection in langchain-ai/langchain

> Attackers can inject SQL via filter operators in LangGraph's SQLite store to exfiltrate sensitive data and bypass security filters.

- **Severity:** High 7.3 (`CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Oct 2025
- **Updated:** 28 Oct 2025
- **Also known as:** GHSA-4h97-wpxp-3757, PYSEC-2026-1528

## What is CVE-2025-8709?

CVE-2025-8709 is a high-severity SQL injection vulnerability in langchain-ai/langchain, published on 26 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A SQL injection vulnerability exists in the langchain-ai/langchain repository, specifically in the LangGraph's SQLite store implementation. The affected version is langgraph-checkpoint-sqlite 2.0.10. The vulnerability arises from improper handling of filter operators ($eq, $ne, $gt, $lt, $gte, $lte) where direct string concatenation is used without proper parameterization. This allows attackers to inject arbitrary SQL, leading to unauthorized access to all documents, data exfiltration of sensitive fields such as passwords and API keys, and a complete bypass of application-level security filters.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-8709?

3 open source packages ship an affected version, including langgraph-checkpoint-sqlite.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `langgraph-checkpoint-sqlite` | PyPI | All versions | 2.0.11 |
| `langgraph-checkpoint-sqlite` | PyPI | All versions | 2.0.11 |
| `langgraph-checkpoint-sqlite` | PyPI | All versions | 2.0.11 |

## How do I fix CVE-2025-8709?

Upgrade langgraph-checkpoint-sqlite to 2.0.11 or later.

## Is CVE-2025-8709 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8709 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8709 and fix it if it is affected.

What it is: CVE-2025-8709 is a high-severity SQL injection vulnerability in langchain-ai/langchain, published on 26 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8709 exists.

Affected packages and fixed versions:
- langgraph-checkpoint-sqlite (PyPI): affected all versions; fixed in 2.0.11
- langgraph-checkpoint-sqlite (PyPI): affected all versions; fixed in 2.0.11
- langgraph-checkpoint-sqlite (PyPI): affected all versions; fixed in 2.0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8709/ (Markdown: https://insights.sbomify.com/CVE-2025-8709/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8709
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8709
- OSV: https://osv.dev/vulnerability/CVE-2025-8709

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8709/
Summaries are generated and may contain mistakes; the official description above is the record.
