{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8746 exists.","fix":"Product is end of life, replace it.","what":"CVE-2025-8746 is a medium-severity memory corruption vulnerability in GNU libopts, published on 9 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-8746 and fix it if it is affected.\n\nWhat it is: CVE-2025-8746 is a medium-severity memory corruption vulnerability in GNU libopts, published on 9 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8746 exists.\n\nAffected product: GNU libopts. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-8746/ (Markdown: https://insights.sbomify.com/CVE-2025-8746/index.md)","id":"CVE-2025-8746","markdown":"https://insights.sbomify.com/CVE-2025-8746/index.md","name":"CVE-2025-8746","record":{"aliases":["DEBIAN-CVE-2025-8746","GHSA-4cc6-crfh-q58w","OESA-2026-1254","OESA-2026-1255","OESA-2026-1256","OESA-2026-1317","OESA-2026-1318","OESA-2026-1424","SUSE-SU-2026:20590-1","UBUNTU-CVE-2025-8746","openSUSE-SU-2025:15557-1","openSUSE-SU-2025:15570-1","openSUSE-SU-2026:20270-1"],"analysis":{"component_type":"library","fix_type":"end_of_life","impacts":["code_execution","privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"GNU libopts library","requires_auth":"low_privilege","summary":"Local attackers can exploit memory corruption in GNU libopts to potentially execute code or escalate privileges, affecting unsupported versions.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"libopts","vendor":"gnu"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A vulnerability, which was classified as problematic, was found in GNU libopts up to 27.6. Affected is the function __strstr_sse2. The manipulation leads to memory corruption. Local access is required to approach this attack. The exploit has been disclosed to the public and may be used. This issue was initially reported to the tcpreplay project, but the code maintainer explains, that this \"bug appears to be in libopts which is an external library.\" This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":["SUSE:Linux Enterprise Server 16.0","SUSE:Linux Enterprise Server for SAP applications 16.0","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"GNU libopts __strstr_sse2 memory corruption","id":"CVE-2025-8746","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":5,"n_references":7,"next":{"headline":"Keras safe_mode bypass allows arbitrary code execution when loading a malicious model.","id":"CVE-2025-8747"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["5.18.16-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"autogen","purl":"pkg:rpm/suse/autogen\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2026:20590-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["5.18.16-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"autogen","purl":"pkg:rpm/suse/autogen\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2026:20590-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["5.18.16-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"autogen","purl":"pkg:rpm/opensuse/autogen\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:20270-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["5.18.16-8.1"],"introduced":["0"],"last_affected":[],"package":"autogen","purl":"pkg:rpm/opensuse/autogen\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15557-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.5.1-2.1"],"introduced":["0"],"last_affected":[],"package":"tcpreplay","purl":"pkg:rpm/opensuse/tcpreplay\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15570-1"}],"prev":{"headline":"Weee RICEPO App com.ricepo.app AndroidManifest.xml improper export of android application components","id":"CVE-2025-8745"},"products":["libopts"],"published":"2025-08-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-11","vendors":["GNU"]},"summary":"Local attackers can exploit memory corruption in GNU libopts to potentially execute code or escalate privileges, affecting unsupported versions.","url":"https://insights.sbomify.com/CVE-2025-8746/"}