# CVE-2025-8747: Keras safe_mode bypass allows arbitrary code execution when loading a malicious model.

> Attackers can execute arbitrary code by tricking users into loading malicious Keras model files, bypassing safe mode protections.

- **Severity:** High 8.6 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/AU:Y/R:A`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Aug 2025
- **Updated:** 26 Feb 2026
- **Also known as:** AZL-66171, GHSA-c9rc-mg46-23w3, PYSEC-2025-75, UBUNTU-CVE-2025-8747

## What is CVE-2025-8747?

CVE-2025-8747 is a high-severity unsafe deserialization vulnerability in Google Keras, published on 11 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A safe mode bypass vulnerability in the `Model.load_model` method in Keras versions 3.0.0 through 3.10.0 allows an attacker to achieve arbitrary code execution by convincing a user to load a specially crafted `.keras` model archive.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-8747?

3 open source packages ship an affected version, including keras. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `keras` | PyPI | All versions | None |
| `keras` | PyPI | From 3.0.0 | 3.11.0 |
| `keras` | PyPI | From 3.0.0 | 3.11.0 |

Products: Keras Keras.

## How do I fix CVE-2025-8747?

Upgrade keras to 3.11.0 or later.

## Is CVE-2025-8747 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8747 exists.

## Other vulnerabilities in Google Keras

- [CVE-2024-3660](https://insights.sbomify.com/CVE-2024-3660/): Arbitrary code injection vulnerability in Keras framework < 2.13 (critical 9.8)
- [CVE-2026-12481](https://insights.sbomify.com/CVE-2026-12481/): Deserialization of Untrusted Data in keras-team/keras (high 8.8)
- [CVE-2026-1462](https://insights.sbomify.com/CVE-2026-1462/): Safe Mode Bypass in keras-team/keras (high 8.8)
- [CVE-2025-9906](https://insights.sbomify.com/CVE-2025-9906/): Arbitrary Code execution in Keras Safe Mode (high 8.6)
- [CVE-2026-11816](https://insights.sbomify.com/CVE-2026-11816/): Path Traversal in keras-team/keras (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8747 and fix it if it is affected.

What it is: CVE-2025-8747 is a high-severity unsafe deserialization vulnerability in Google Keras, published on 11 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8747 exists.

Affected packages and fixed versions:
- keras (PyPI): affected all versions; no fix listed
- keras (PyPI): affected from 3.0.0; fixed in 3.11.0
- keras (PyPI): affected from 3.0.0; fixed in 3.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8747/ (Markdown: https://insights.sbomify.com/CVE-2025-8747/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8747
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8747
- OSV: https://osv.dev/vulnerability/CVE-2025-8747

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8747/
Summaries are generated and may contain mistakes; the official description above is the record.
