CVE-2025-8770 Authorization Bypass Through User-Controlled Key in GitLab
Authenticated users can bypass merge request approval policies by manipulating approval rule identifiers in GitLab Enterprise Edition.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-8770?
CVE-2025-8770 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 13 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue has been discovered in GitLab EE affecting all versions from 18.0 prior to 18.0.6, 18.1 prior to 18.1.4, and 18.2 prior to 18.2.2 that could have allowed authenticated users with specific access to bypass merge request approval policies by manipulating approval rule identifiers.
Weakness: CWE-639
Which versions are affected by CVE-2025-8770?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 18.0.0 | 18.0.6, 18.1.4, 18.2.2 |
Products include Gitlab Gitlab.
How do I fix CVE-2025-8770?
Upgrade gitlab to a fixed version for your release line: 18.0.6, 18.1.4 or 18.2.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-8770 being exploited?
There is no known exploitation of CVE-2025-8770 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2025-8770, GHSA-gxh9-4vgj-w44j, UBUNTU-CVE-2025-8770.