CVE-2025-8800 Open5GS AMF esm-handler.c esm_handle_pdn_connectivity_request denial of service

Medium 6.9 Published Updated

Remote attackers can cause a denial of service in Open5GS AMF by exploiting a flaw in the PDN connectivity request handler, requiring an upgrade to mitigate.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-8800?

CVE-2025-8800 is a medium-severity denial of service vulnerability in Open5gs Open5gs, published on 10 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A vulnerability has been found in Open5GS up to 2.7.5. Affected by this issue is the function esm_handle_pdn_connectivity_request of the file src/mme/esm-handler.c of the component AMF Component. The manipulation leads to denial of service. The attack may be launched remotely. Upgrading to version 2.7.6 is able to address this issue. The name of the patch is 701505102f514cbde2856cd2ebc9bedb7efc820d. It is recommended to upgrade the affected component.

Weakness: CWE-404

Which versions are affected by CVE-2025-8800?

It affects 1 product.

Products include Open5gs Open5gs.

How do I fix CVE-2025-8800?

No fix has been published for CVE-2025-8800 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-8800 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8800 exists.

All Open5gs Open5gs vulnerabilities

Sources

Also known as GHSA-hw62-xfc6-h8r3.

Is CVE-2025-8800 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free