# CVE-2025-8800: Open5GS AMF esm-handler.c esm_handle_pdn_connectivity_request denial of service

> Remote attackers can cause a denial of service in Open5GS AMF by exploiting a flaw in the PDN connectivity request handler, requiring an upgrade to mitigate.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 10 Aug 2025
- **Updated:** 15 Aug 2025
- **Also known as:** GHSA-hw62-xfc6-h8r3

## What is CVE-2025-8800?

CVE-2025-8800 is a medium-severity denial of service vulnerability in Open5gs Open5gs, published on 10 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability has been found in Open5GS up to 2.7.5. Affected by this issue is the function esm_handle_pdn_connectivity_request of the file src/mme/esm-handler.c of the component AMF Component. The manipulation leads to denial of service. The attack may be launched remotely. Upgrading to version 2.7.6 is able to address this issue. The name of the patch is 701505102f514cbde2856cd2ebc9bedb7efc820d. It is recommended to upgrade the affected component.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2025-8800?

It affects 1 product.


Products: Open5gs Open5gs.

## How do I fix CVE-2025-8800?

No fix has been published for CVE-2025-8800 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-8800 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8800 exists.

## Other vulnerabilities in Open5gs Open5gs

- [CVE-2024-40130](https://insights.sbomify.com/CVE-2024-40130/): Memory corruption in n/a (critical 9.8)
- [CVE-2021-28122](https://insights.sbomify.com/CVE-2021-28122/): Missing authorization in n/a (critical 9.8)
- [CVE-2021-25863](https://insights.sbomify.com/CVE-2021-25863/): Hardcoded credentials in n/a (high 8.8)
- [CVE-2025-41067](https://insights.sbomify.com/CVE-2025-41067/): Reachable Assertion vulnerability in Open5GS (high 8.7)
- [CVE-2025-41068](https://insights.sbomify.com/CVE-2025-41068/): Reachable Assertion vulnerability in Open5GS (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8800 and fix it if it is affected.

What it is: CVE-2025-8800 is a medium-severity denial of service vulnerability in Open5gs Open5gs, published on 10 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8800 exists.

Affected product: Open5gs Open5gs. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8800/ (Markdown: https://insights.sbomify.com/CVE-2025-8800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8800
- OSV: https://osv.dev/vulnerability/CVE-2025-8800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8800/
Summaries are generated and may contain mistakes; the official description above is the record.
