{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8801 exists.","fix":"No fix has been published for CVE-2025-8801 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-8801 is a medium-severity denial of service vulnerability in Open5gs Open5gs, published on 10 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-8801 and fix it if it is affected.\n\nWhat it is: CVE-2025-8801 is a medium-severity denial of service vulnerability in Open5gs Open5gs, published on 10 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8801 exists.\n\nAffected product: Open5gs Open5gs. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-8801/ (Markdown: https://insights.sbomify.com/CVE-2025-8801/index.md)","id":"CVE-2025-8801","markdown":"https://insights.sbomify.com/CVE-2025-8801/index.md","name":"CVE-2025-8801","record":{"aliases":["GHSA-wq4p-mpxw-hmg5"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"5G core network software","requires_auth":"none","summary":"Remote attackers can cause a denial of service in Open5GS AMF by exploiting a flaw in the gmm_state_exception function.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"open5gs","vendor":"open5gs"}],"cvss":{"score":6.9,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-404","name":"Improper Resource Shutdown or Release"}],"description":"A vulnerability was found in Open5GS up to 2.7.5. This affects the function gmm_state_exception of the file src/amf/gmm-sm.c of the component AMF. The manipulation leads to denial of service. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 2.7.6 is able to address this issue. The identifier of the patch is f47f2bd4f7274295c5fbb19e2f806753d183d09a. It is recommended to upgrade the affected component.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Open5GS AMF gmm-sm.c gmm_state_exception denial of service","id":"CVE-2025-8801","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"open5gs:open5gs","products":["open5gs:open5gs"],"type":"denial_of_service","year":"2025"},"n_packages":0,"n_references":9,"next":{"headline":"Open5GS SMF smf-sm.c smf_state_operational denial of service","id":"CVE-2025-8802"},"packages":[],"prev":{"headline":"Open5GS AMF esm-handler.c esm_handle_pdn_connectivity_request denial of service","id":"CVE-2025-8800"},"products":["Open5GS"],"published":"2025-08-10","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2024-40130","kev_date_added":null,"published":"2024-07-16"},{"cvss_score":9.8,"headline":"Missing authorization in n/a","id":"CVE-2021-28122","kev_date_added":null,"published":"2021-03-10"},{"cvss_score":8.8,"headline":"Hardcoded credentials in n/a","id":"CVE-2021-25863","kev_date_added":null,"published":"2021-01-26"},{"cvss_score":8.7,"headline":"Reachable Assertion vulnerability in Open5GS","id":"CVE-2025-41067","kev_date_added":null,"published":"2025-10-27"},{"cvss_score":8.7,"headline":"Reachable Assertion vulnerability in Open5GS","id":"CVE-2025-41068","kev_date_added":null,"published":"2025-10-27"},{"cvss_score":8.6,"headline":"Denial of service in n/a","id":"CVE-2023-37015","kev_date_added":null,"published":"2025-01-22"},{"cvss_score":8.6,"headline":"Denial of service in n/a","id":"CVE-2023-37016","kev_date_added":null,"published":"2025-01-22"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-15","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service in Open5GS AMF by exploiting a flaw in the gmm_state_exception function.","url":"https://insights.sbomify.com/CVE-2025-8801/"}