# CVE-2025-8891: OceanWP <= 4.0.9 - 4.1.1 - Cross-Site Request Forgery to Ocean Extra Plugin Installation

> Attackers can trick admins into installing the Ocean Extra plugin via CSRF, potentially leading to code execution.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 13 Aug 2025
- **Updated:** 26 Aug 2025
- **Also known as:** GHSA-749m-qq5p-qp89

## What is CVE-2025-8891?

CVE-2025-8891 is a medium-severity vulnerability in OceanWP, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The OceanWP theme for WordPress is vulnerable to Cross-Site Request Forgery in versions 4.0.9 to 4.1.1. This is due to missing or incorrect nonce validation on the oceanwp_notice_button_click() function. This makes it possible for unauthenticated attackers to install the Ocean Extra plugin via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-8891?

It affects 1 product.


Products: Oceanwp Oceanwp.

## How do I fix CVE-2025-8891?

No fix has been published for CVE-2025-8891 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-8891 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8891 exists.

## Other vulnerabilities in OceanWP

- [CVE-2025-8944](https://insights.sbomify.com/CVE-2025-8944/): OceanWP < 4.1.2 - Subscriber+ Limited Option Update (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8891 and fix it if it is affected.

What it is: CVE-2025-8891 is a medium-severity vulnerability in OceanWP, published on 13 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8891 exists.

Affected product: OceanWP. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8891/ (Markdown: https://insights.sbomify.com/CVE-2025-8891/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8891
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8891
- OSV: https://osv.dev/vulnerability/CVE-2025-8891

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8891/
Summaries are generated and may contain mistakes; the official description above is the record.
