# CVE-2025-8904: Privilege escalation issue in Amazon EMR Secret Agent component

> A local user can escalate privileges by accessing Kerberos credentials stored in a world-readable temporary directory within Amazon EMR.

- **Severity:** Critical 9.0 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Aug 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-hf8h-76fm-735v

## What is CVE-2025-8904?

CVE-2025-8904 is a critical vulnerability in Amazon EMR, published on 13 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Amazon EMR Secret Agent creates a keytab file containing Kerberos credentials. This file is stored in the /tmp/ directory. A user with access to this directory and another account can potentially decrypt the keys and escalate to higher privileges. 

Users are advised to upgrade to Amazon EMR version 7.5 or higher. For Amazon EMR releases between 6.10 and 7.4, we strongly recommend that you run the bootstrap script and RPM files with the fix provided in the location below.

Weakness: CWE-257 (Storing Passwords in a Recoverable Format)

## Which versions are affected by CVE-2025-8904?


## How do I fix CVE-2025-8904?

No fix has been published for CVE-2025-8904 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-8904 being exploited?

There is no known exploitation of CVE-2025-8904 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8904 and fix it if it is affected.

What it is: CVE-2025-8904 is a critical vulnerability in Amazon EMR, published on 13 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-8904 in the wild and no public exploit code.

Affected product: Amazon EMR. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8904/ (Markdown: https://insights.sbomify.com/CVE-2025-8904/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8904
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8904
- OSV: https://osv.dev/vulnerability/CVE-2025-8904

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8904/
Summaries are generated and may contain mistakes; the official description above is the record.
