# CVE-2025-8917: Path Traversal Leading to Remote Code Execution in allegroai/clearml

> Path traversal in allegroai/clearml allows arbitrary file writes via symlink handling, potentially leading to remote code execution.

- **Severity:** Medium 5.8 (`CVSS:3.0/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Oct 2025
- **Updated:** 6 Oct 2025
- **Also known as:** GHSA-579p-qf78-fqm2, PYSEC-2026-1255

## What is CVE-2025-8917?

CVE-2025-8917 is a medium-severity path traversal vulnerability in allegroai/clearml, published on 5 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A vulnerability in allegroai/clearml version v2.0.1 allows for path traversal due to improper handling of symbolic and hard links in the `safe_extract` function. This flaw can lead to arbitrary file writes outside the intended directory, potentially resulting in remote code execution if critical files are overwritten.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-8917?

3 open source packages ship an affected version, including clearml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `clearml` | PyPI | All versions | 2.0.2 |
| `clearml` | PyPI | All versions | 2.0.2 |
| `clearml` | PyPI | All versions | 2.0.2 |

## How do I fix CVE-2025-8917?

Upgrade clearml to 2.0.2 or later.

## Is CVE-2025-8917 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8917 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-8917 and fix it if it is affected.

What it is: CVE-2025-8917 is a medium-severity path traversal vulnerability in allegroai/clearml, published on 5 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8917 exists.

Affected packages and fixed versions:
- clearml (PyPI): affected all versions; fixed in 2.0.2
- clearml (PyPI): affected all versions; fixed in 2.0.2
- clearml (PyPI): affected all versions; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-8917/ (Markdown: https://insights.sbomify.com/CVE-2025-8917/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-8917
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-8917
- OSV: https://osv.dev/vulnerability/CVE-2025-8917

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-8917/
Summaries are generated and may contain mistakes; the official description above is the record.
