CVE-2025-8976 givanz Vvveb Endpoint post cross site scripting

Medium 5.1 Published Updated

Remote attackers can inject malicious scripts via the post endpoint, potentially leading to code execution or account takeover in Vvveb CMS.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-8976?

CVE-2025-8976 is a medium-severity cross-site scripting vulnerability in givanz Vvveb, published on 14 Aug 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability has been found in givanz Vvveb up to 1.0.5. This vulnerability affects unknown code of the file /vadmin123/index.php?module=content/post&type=post of the component Endpoint. The manipulation leads to cross site scripting. The attack can be initiated remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.0.6 is able to address this issue. It is recommended to upgrade the affected component.

Weakness: CWE-94, CWE-79

Which versions are affected by CVE-2025-8976?

It affects 1 product.

Products include Vvveb Vvveb.

How do I fix CVE-2025-8976?

No fix has been published for CVE-2025-8976 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-8976 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-8976 exists.

Sources

Also known as GHSA-g9xv-6j77-3wfx.

Is CVE-2025-8976 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free