CVE-2025-9072 One-Click Mattermost Account Takeover via Poisoned RelayState SAML Parameter
Attackers can steal user cookies via a malicious SAML redirect link, leading to account takeover in Mattermost deployments using SAML authentication.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-9072?
CVE-2025-9072 is a high-severity vulnerability in Mattermost Mattermost Server, published on 15 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Mattermost versions 10.10.x <= 10.10.1, 10.5.x <= 10.5.9, 10.9.x <= 10.9.4 fail to validate the redirect_to parameter, allowing an attacker to craft a malicious link that, once a user authenticates with their SAML provider, could post the user’s cookies to an attacker-controlled URL.
Weakness: CWE-601
Which versions are affected by CVE-2025-9072?
12 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.10.0 | 10.10.2 |
github.com/mattermost/mattermost-server Go | From 10.10.0 | 10.10.2 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.10 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.10 |
github.com/mattermost/mattermost-server Go | From 10.5.0+incompatible | 10.5.10+incompatible, 10.9.5+incompatible, 10.10.2+incompatible |
github.com/mattermost/mattermost-server Go | From 10.9.0 | 10.9.5 |
6 more packages
github.com/mattermost/mattermost-server Go | From 10.9.0 | 10.9.5 |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250731063404-9eebaadf8f72 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250731063404-9eebaadf8f72 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250731063404-9eebaadf8f72 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-9072?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.10.2, 10.5.10, 10.5.10+incompatible or 10.9.5+incompatible.
Is CVE-2025-9072 being exploited?
There is no known exploitation of CVE-2025-9072 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-69j8-prx2-vx98, GO-2025-3958.