CVE-2025-9076 Mattermost Server exposes sensitive user credentials during shared channel membership synchronization
Mattermost Server leaks sensitive user credentials to remote clusters during shared channel synchronization when the feature is enabled.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-9076?
CVE-2025-9076 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 15 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 10.10.x <= 10.10.1 fail to properly sanitize user data during shared channel membership synchronization, which allows malicious or compromised remote clusters to access sensitive user information via unsanitized user objects. This vulnerability affects Mattermost Server instances with shared channels enabled.
Weakness: CWE-862
Which versions are affected by CVE-2025-9076?
8 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.10.0 | 10.10.2 |
github.com/mattermost/mattermost-server Go | From 10.10.0 | 10.10.2 |
github.com/mattermost/mattermost-server Go | From 10.10.0+incompatible | 10.10.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | None |
2 more packages
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250729073403-517ae758cd02 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250729073403-517ae758cd02 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-9076?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.10.2 or 10.10.2+incompatible.
Is CVE-2025-9076 being exploited?
There is no known exploitation of CVE-2025-9076 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-3vcm-c42p-3hhf, GO-2025-3950.