# CVE-2025-9076: Mattermost Server exposes sensitive user credentials during shared channel membership synchronization

> Mattermost Server leaks sensitive user credentials to remote clusters during shared channel synchronization when the feature is enabled.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2025
- **Updated:** 15 Sep 2025
- **Also known as:** GHSA-3vcm-c42p-3hhf, GO-2025-3950

## What is CVE-2025-9076?

CVE-2025-9076 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 15 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost versions 10.10.x <= 10.10.1 fail to properly sanitize user data during shared channel membership synchronization, which allows malicious or compromised remote clusters to access sensitive user information via unsanitized user objects. This vulnerability affects Mattermost Server instances with shared channels enabled.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2025-9076?

8 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.10.0 | 10.10.2 |
| `github.com/mattermost/mattermost-server` | Go | From 10.10.0 | 10.10.2 |
| `github.com/mattermost/mattermost-server` | Go | From 10.10.0+incompatible | 10.10.2+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250729073403-517ae758cd02 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250729073403-517ae758cd02 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-9076?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.10.2 or 10.10.2+incompatible.

## Is CVE-2025-9076 being exploited?

There is no known exploitation of CVE-2025-9076 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-9076 and fix it if it is affected.

What it is: CVE-2025-9076 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 15 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-9076 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.10.0; fixed in 10.10.2
- github.com/mattermost/mattermost-server (Go): affected from 10.10.0; fixed in 10.10.2
- github.com/mattermost/mattermost-server (Go): affected from 10.10.0+incompatible; fixed in 10.10.2+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250729073403-517ae758cd02
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250729073403-517ae758cd02

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-9076/ (Markdown: https://insights.sbomify.com/CVE-2025-9076/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-9076
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-9076
- OSV: https://osv.dev/vulnerability/CVE-2025-9076

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-9076/
Summaries are generated and may contain mistakes; the official description above is the record.
