CVE-2025-9078 Weak cache keys lead to post IDOR and link preview poisoning
Authenticated users can access unauthorized posts and poison link previews due to weak FNV-1 hashing in cache keys.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-9078?
CVE-2025-9078 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 15 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.10.x <= 10.10.1, 10.9.x <= 10.9.3 fail to properly validate cache keys for link metadata which allows authenticated users to access unauthorized posts and poison link previews via hash collision attacks on FNV-1 hashing
Weakness: CWE-328
Which versions are affected by CVE-2025-9078?
16 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.10.0 | 10.10.2 |
github.com/mattermost/mattermost-server Go | From 10.10.0 | 10.10.2 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.9 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.9 |
github.com/mattermost/mattermost-server Go | From 10.8.0 | 10.8.4 |
github.com/mattermost/mattermost-server Go | From 10.8.0 | 10.8.4 |
10 more packages
github.com/mattermost/mattermost-server Go | From 10.9.0 | 10.9.4 |
github.com/mattermost/mattermost-server Go | From 10.9.0 | 10.9.4 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.18 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.18 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.18+incompatible, 10.5.9+incompatible, 10.8.4+incompatible, 10.9.4+incompatible, 10.10.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250718075842-cd87e5c87737 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250718075842-cd87e5c87737 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250718075842-cd87e5c87737 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-9078?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.10.2, 10.5.9, 10.8.4 or 10.9.4.
Is CVE-2025-9078 being exploited?
There is no known exploitation of CVE-2025-9078 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-9p92-x77w-9fw2, GO-2025-3959.