CVE-2025-9079 Admin RCE via prepackaged plugins by way of misconfigured imports directory
Admin users can execute arbitrary code by uploading malicious plugins to a prepackaged directory due to insufficient path validation.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-9079?
CVE-2025-9079 is a high-severity path traversal vulnerability in Mattermost Mattermost Server, published on 19 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.10.x <= 10.10.1, 10.9.x <= 10.9.3 fail to validate import directory path configuration which allows admin users to execute arbitrary code via malicious plugin upload to prepackaged plugins directory
Weakness: CWE-22
Which versions are affected by CVE-2025-9079?
16 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.10.0 | 10.10.2 |
github.com/mattermost/mattermost-server Go | From 10.10.0 | 10.10.2 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.9 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.9 |
github.com/mattermost/mattermost-server Go | From 10.8.0 | 10.8.4 |
github.com/mattermost/mattermost-server Go | From 10.8.0 | 10.8.4 |
10 more packages
github.com/mattermost/mattermost-server Go | From 10.9.0 | 10.9.4 |
github.com/mattermost/mattermost-server Go | From 10.9.0 | 10.9.4 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.18 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.18 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.18+incompatible, 10.5.9+incompatible, 10.8.4+incompatible, 10.9.4+incompatible, 10.10.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250707221302-a8fa77f107ef |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250707221302-a8fa77f107ef |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250707221302-a8fa77f107ef |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-9079?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.10.2, 10.5.9, 10.8.4 or 10.9.4.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-9079 being exploited?
There is no known exploitation of CVE-2025-9079 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-qx3f-6vq3-8j8m, GO-2025-3977.