# CVE-2025-9079: Admin RCE via prepackaged plugins by way of misconfigured imports directory

> Admin users can execute arbitrary code by uploading malicious plugins to a prepackaged directory due to insufficient path validation.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-qx3f-6vq3-8j8m, GO-2025-3977

## What is CVE-2025-9079?

CVE-2025-9079 is a high-severity path traversal vulnerability in Mattermost Mattermost Server, published on 19 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mattermost versions 10.8.x <= 10.8.3, 10.5.x <= 10.5.8, 9.11.x <= 9.11.17, 10.10.x <= 10.10.1, 10.9.x <= 10.9.3 fail to validate import directory path configuration which allows admin users to execute arbitrary code via malicious plugin upload to prepackaged plugins directory

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-9079?

16 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.10.0 | 10.10.2 |
| `github.com/mattermost/mattermost-server` | Go | From 10.10.0 | 10.10.2 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.9 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0 | 10.5.9 |
| `github.com/mattermost/mattermost-server` | Go | From 10.8.0 | 10.8.4 |
| `github.com/mattermost/mattermost-server` | Go | From 10.8.0 | 10.8.4 |
| `github.com/mattermost/mattermost-server` | Go | From 10.9.0 | 10.9.4 |
| `github.com/mattermost/mattermost-server` | Go | From 10.9.0 | 10.9.4 |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0 | 9.11.18 |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0 | 9.11.18 |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0+incompatible | 9.11.18+incompatible, 10.5.9+incompatible, 10.8.4+incompatible, 10.9.4+incompatible, 10.10.2+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250707221302-a8fa77f107ef |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250707221302-a8fa77f107ef |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250707221302-a8fa77f107ef |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-9079?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.10.2, 10.5.9, 10.8.4 or 10.9.4.

## Is CVE-2025-9079 being exploited?

There is no known exploitation of CVE-2025-9079 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-9079 and fix it if it is affected.

What it is: CVE-2025-9079 is a high-severity path traversal vulnerability in Mattermost Mattermost Server, published on 19 Sep 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-9079 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.10.0; fixed in 10.10.2
- github.com/mattermost/mattermost-server (Go): affected from 10.10.0; fixed in 10.10.2
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.9
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0; fixed in 10.5.9
- github.com/mattermost/mattermost-server (Go): affected from 10.8.0; fixed in 10.8.4
- github.com/mattermost/mattermost-server (Go): affected from 10.8.0; fixed in 10.8.4
- github.com/mattermost/mattermost-server (Go): affected from 10.9.0; fixed in 10.9.4
- github.com/mattermost/mattermost-server (Go): affected from 10.9.0; fixed in 10.9.4
- github.com/mattermost/mattermost-server (Go): affected from 9.11.0; fixed in 9.11.18
- github.com/mattermost/mattermost-server (Go): affected from 9.11.0; fixed in 9.11.18
- github.com/mattermost/mattermost-server (Go): affected from 9.11.0+incompatible; fixed in 9.11.18+incompatible, 10.5.9+incompatible, 10.8.4+incompatible, 10.9.4+incompatible, 10.10.2+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-9079/ (Markdown: https://insights.sbomify.com/CVE-2025-9079/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-9079
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-9079
- OSV: https://osv.dev/vulnerability/CVE-2025-9079

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-9079/
Summaries are generated and may contain mistakes; the official description above is the record.
