CVE-2025-9081 IDOR in board file download allows any user to download any file by UUID
Authenticated users can download any file by enumerating UUIDs due to missing access controls in the board file download endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-9081?
CVE-2025-9081 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 19 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.5.x <= 10.5.8, 9.11.x <= 9.11.17 fail to properly validate access controls which allows any authenticated user to download sensitive files via board file download endpoint using UUID enumeration
Weakness: CWE-639
Which versions are affected by CVE-2025-9081?
13 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-plugin-boards and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.5.0-rc1 | 10.5.9 |
github.com/mattermost/mattermost-server Go | From 10.5.0-rc1 | 10.5.9 |
github.com/mattermost/mattermost-server Go | From 9.11.0-rc1 | 9.11.18 |
github.com/mattermost/mattermost-server Go | From 9.11.0-rc1 | 9.11.18 |
github.com/mattermost/mattermost-server Go | From 9.11.0-rc1+incompatible | 9.11.18+incompatible, 10.5.9+incompatible |
github.com/mattermost/mattermost-plugin-boards Go | All versions | 0.0.0-20250716054606-3f3e3becfe1d |
7 more packages
github.com/mattermost/mattermost-plugin-boards Go | All versions | 0.0.0-20250716054606-3f3e3becfe1d |
github.com/mattermost/mattermost-plugin-boards Go | All versions | 0.0.0-20250716054606-3f3e3becfe1d |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250721095935-11c36f4d1e44 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250721095935-11c36f4d1e44 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250721095935-11c36f4d1e44 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-9081?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.9, 9.11.18, 9.11.18+incompatible or 10.5.9+incompatible.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-9081 being exploited?
There is no known exploitation of CVE-2025-9081 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-f72g-52v7-mg3p, GO-2025-3978.