# CVE-2025-9081: IDOR in board file download allows any user to download any file by UUID

> Authenticated users can download any file by enumerating UUIDs due to missing access controls in the board file download endpoint.

- **Severity:** Low 3.1 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Sep 2025
- **Updated:** 19 Sep 2025
- **Also known as:** GHSA-f72g-52v7-mg3p, GO-2025-3978

## What is CVE-2025-9081?

CVE-2025-9081 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 19 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost versions 10.5.x <= 10.5.8, 9.11.x <= 9.11.17 fail to properly validate access controls which allows any authenticated user to download sensitive files via board file download endpoint using UUID enumeration

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2025-9081?

13 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-plugin-boards and github.com/mattermost/mattermost-server/v5. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0-rc1 | 10.5.9 |
| `github.com/mattermost/mattermost-server` | Go | From 10.5.0-rc1 | 10.5.9 |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0-rc1 | 9.11.18 |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0-rc1 | 9.11.18 |
| `github.com/mattermost/mattermost-server` | Go | From 9.11.0-rc1+incompatible | 9.11.18+incompatible, 10.5.9+incompatible |
| `github.com/mattermost/mattermost-plugin-boards` | Go | All versions | 0.0.0-20250716054606-3f3e3becfe1d |
| `github.com/mattermost/mattermost-plugin-boards` | Go | All versions | 0.0.0-20250716054606-3f3e3becfe1d |
| `github.com/mattermost/mattermost-plugin-boards` | Go | All versions | 0.0.0-20250716054606-3f3e3becfe1d |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250721095935-11c36f4d1e44 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250721095935-11c36f4d1e44 |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | 8.0.0-20250721095935-11c36f4d1e44 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-9081?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.9, 9.11.18, 9.11.18+incompatible or 10.5.9+incompatible.

## Is CVE-2025-9081 being exploited?

There is no known exploitation of CVE-2025-9081 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-9081 and fix it if it is affected.

What it is: CVE-2025-9081 is a low-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 19 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-9081 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0-rc1; fixed in 10.5.9
- github.com/mattermost/mattermost-server (Go): affected from 10.5.0-rc1; fixed in 10.5.9
- github.com/mattermost/mattermost-server (Go): affected from 9.11.0-rc1; fixed in 9.11.18
- github.com/mattermost/mattermost-server (Go): affected from 9.11.0-rc1; fixed in 9.11.18
- github.com/mattermost/mattermost-server (Go): affected from 9.11.0-rc1+incompatible; fixed in 9.11.18+incompatible, 10.5.9+incompatible
- github.com/mattermost/mattermost-plugin-boards (Go): affected all versions; fixed in 0.0.0-20250716054606-3f3e3becfe1d
- github.com/mattermost/mattermost-plugin-boards (Go): affected all versions; fixed in 0.0.0-20250716054606-3f3e3becfe1d
- github.com/mattermost/mattermost-plugin-boards (Go): affected all versions; fixed in 0.0.0-20250716054606-3f3e3becfe1d
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250721095935-11c36f4d1e44
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; fixed in 8.0.0-20250721095935-11c36f4d1e44

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-9081/ (Markdown: https://insights.sbomify.com/CVE-2025-9081/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-9081
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-9081
- OSV: https://osv.dev/vulnerability/CVE-2025-9081

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-9081/
Summaries are generated and may contain mistakes; the official description above is the record.
