CVE-2025-9084 Open redirect in OAuth login

Low 3.1 Published Updated

Attackers can redirect users to malicious sites via crafted OAuth login URLs in Mattermost, potentially facilitating phishing attacks.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-9084?

CVE-2025-9084 is a low-severity vulnerability in Mattermost Mattermost Server, published on 15 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Mattermost versions 10.5.x <= 10.5.9 fail to properly validate redirect URLs which allows attackers to redirect users to malicious sites via crafted OAuth login URLs

Weakness: CWE-601

Which versions are affected by CVE-2025-9084?

8 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost-server GoFrom 10.5.010.5.10
github.com/mattermost/mattermost-server GoFrom 10.5.010.5.10
github.com/mattermost/mattermost-server GoFrom 10.5.0+incompatible10.5.10+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone
github.com/mattermost/mattermost/server/v8 GoAll versionsNone
2 more packages
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-202508080704-39bd251fe4f600
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-202508080704-39bd251fe4f600

Products include Mattermost Mattermost Server.

How do I fix CVE-2025-9084?

Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.10 or 10.5.10+incompatible.

Is CVE-2025-9084 being exploited?

There is no known exploitation of CVE-2025-9084 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-hm95-jx66-g2gh, GO-2025-3960.

Is CVE-2025-9084 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free