{"answers":{"affected":"2 open source packages ship an affected version, including org.bouncycastle:bc-fips.","exploited":"There is no known exploitation of CVE-2025-9092 in the wild and no public exploit code.","fix":"Upgrade org.bouncycastle:bc-fips to 2.1.1 or later.","what":"CVE-2025-9092 is a low-severity denial of service vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java - BC-FJA 2.1.0, published on 16 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-9092 and fix it if it is affected.\n\nWhat it is: CVE-2025-9092 is a low-severity denial of service vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java - BC-FJA 2.1.0, published on 16 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-9092 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.bouncycastle:bc-fips (Maven): affected from 2.1.0; fixed in 2.1.1\n- org.bouncycastle:bc-fips (Maven): affected from 2.1.0; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-9092/ (Markdown: https://insights.sbomify.com/CVE-2025-9092/index.md)","id":"CVE-2025-9092","markdown":"https://insights.sbomify.com/CVE-2025-9092/index.md","name":"CVE-2025-9092","record":{"aliases":["GHSA-v6cf-mv9h-c8mc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Java cryptographic library","requires_auth":"high_privilege","summary":"Attackers can cause resource exhaustion in applications using Bouncy Castle FIPS Java API, leading to denial of service.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"bcorg","cpe":[],"cvss":{"score":1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/R:U/RE:L/U:Green","version":"4.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Uncontrolled Resource Consumption vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java - BC-FJA 2.1.0 bc-fips (API modules) allows Excessive Allocation. This vulnerability is associated with program files org.Bouncycastle.Crypto.Fips.NativeLoader.\n\nThis issue affects Bouncy Castle for Java - BC-FJA 2.1.0: from BC-FJA 2.1.0 through 2.1.0.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Hybrid Module Deployment in Multi-JVM Environments Leading to Resource Exhaustion","id":"CVE-2025-9092","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"BuzzFeed App com.buzzfeed.android AndroidManifest.xml improper export of android application components","id":"CVE-2025-9093"},"packages":[{"ecosystem":"Maven","fixed":["2.1.1"],"introduced":["2.1.0"],"last_affected":[],"package":"org.bouncycastle:bc-fips","purl":null,"source":"GHSA-v6cf-mv9h-c8mc"},{"ecosystem":"Maven","fixed":["2.1.1"],"introduced":["2.1.0"],"last_affected":[],"package":"org.bouncycastle:bc-fips","purl":"pkg:maven/org.bouncycastle/bc-fips","source":"GHSA-v6cf-mv9h-c8mc"}],"prev":{"headline":"Tenda AC20 shadow hard-coded credentials","id":"CVE-2025-9091"},"products":["Bouncy Castle for Java - BC-FJA 2.1.0"],"published":"2025-08-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-18","vendors":["Legion of the Bouncy Castle Inc."]},"summary":"Attackers can cause resource exhaustion in applications using Bouncy Castle FIPS Java API, leading to denial of service.","url":"https://insights.sbomify.com/CVE-2025-9092/"}