# CVE-2025-9092: Hybrid Module Deployment in Multi-JVM Environments Leading to Resource Exhaustion

> Attackers can cause resource exhaustion in applications using Bouncy Castle FIPS Java API, leading to denial of service.

- **Severity:** Low 1.0 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:H/UI:A/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/R:U/RE:L/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Aug 2025
- **Updated:** 18 Aug 2025
- **Also known as:** GHSA-v6cf-mv9h-c8mc

## What is CVE-2025-9092?

CVE-2025-9092 is a low-severity denial of service vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java - BC-FJA 2.1.0, published on 16 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Uncontrolled Resource Consumption vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java - BC-FJA 2.1.0 bc-fips (API modules) allows Excessive Allocation. This vulnerability is associated with program files org.Bouncycastle.Crypto.Fips.NativeLoader.

This issue affects Bouncy Castle for Java - BC-FJA 2.1.0: from BC-FJA 2.1.0 through 2.1.0.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-9092?

2 open source packages ship an affected version, including org.bouncycastle:bc-fips.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.bouncycastle:bc-fips` | Maven | From 2.1.0 | 2.1.1 |
| `org.bouncycastle:bc-fips` | Maven | From 2.1.0 | 2.1.1 |

## How do I fix CVE-2025-9092?

Upgrade org.bouncycastle:bc-fips to 2.1.1 or later.

## Is CVE-2025-9092 being exploited?

There is no known exploitation of CVE-2025-9092 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-9092 and fix it if it is affected.

What it is: CVE-2025-9092 is a low-severity denial of service vulnerability in Legion of the Bouncy Castle Inc. Bouncy Castle for Java - BC-FJA 2.1.0, published on 16 Aug 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-9092 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.bouncycastle:bc-fips (Maven): affected from 2.1.0; fixed in 2.1.1
- org.bouncycastle:bc-fips (Maven): affected from 2.1.0; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-9092/ (Markdown: https://insights.sbomify.com/CVE-2025-9092/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-9092
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-9092
- OSV: https://osv.dev/vulnerability/CVE-2025-9092

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-9092/
Summaries are generated and may contain mistakes; the official description above is the record.
