CVE-2025-9222 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 8.7 Published Updated

An authenticated user can achieve stored cross-site scripting via GitLab Flavored Markdown, potentially leading to code execution or account takeover.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-9222?

CVE-2025-9222 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 9 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2.2 before 18.5.5, 18.6 before 18.6.3, and 18.7 before 18.7.1 that could have allowed an authenticated user to achieve stored cross-site scripting by exploiting GitLab Flavored Markdown.

Weakness: CWE-79

Which versions are affected by CVE-2025-9222?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 18.2.218.5.5, 18.6.3, 18.7.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-9222?

Upgrade gitlab to a fixed version for your release line: 18.5.5, 18.6.3 or 18.7.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-9222 being exploited?

There is no known exploitation of CVE-2025-9222 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-9222, GHSA-p9cp-qq4c-2wr5.

Is CVE-2025-9222 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free