{"answers":{"affected":"1 open source package ship an affected version, including gitlab. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-9222 in the wild and no public exploit code.","fix":"Upgrade gitlab to a fixed version for your release line: 18.5.5, 18.6.3 or 18.7.1.","what":"CVE-2025-9222 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 9 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-9222 and fix it if it is affected.\n\nWhat it is: CVE-2025-9222 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 9 Jan 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-9222 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gitlab (Bitnami): affected from 18.2.2; fixed in 18.5.5, 18.6.3, 18.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-9222/ (Markdown: https://insights.sbomify.com/CVE-2025-9222/index.md)","id":"CVE-2025-9222","markdown":"https://insights.sbomify.com/CVE-2025-9222/index.md","name":"CVE-2025-9222","record":{"aliases":["BIT-gitlab-2025-9222","GHSA-p9cp-qq4c-2wr5"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"GitLab","requires_auth":"low_privilege","summary":"An authenticated user can achieve stored cross-site scripting via GitLab Flavored Markdown, potentially leading to code execution or account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitLab","cpe":[{"product":"gitlab","vendor":"gitlab"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"GitLab has remediated an issue in GitLab CE/EE affecting all versions from 18.2.2 before 18.5.5, 18.6 before 18.6.3, and 18.7 before 18.7.1 that could have allowed an authenticated user to achieve stored cross-site scripting by exploiting GitLab Flavored Markdown.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab","id":"CVE-2025-9222","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"gitlab:gitlab","products":["gitlab:gitlab"],"type":"xss","year":"2025"},"n_packages":1,"n_references":3,"next":{"headline":"Command Injection","id":"CVE-2025-9223"},"packages":[{"ecosystem":"Bitnami","fixed":["18.5.5","18.6.3","18.7.1"],"introduced":["18.2.2","18.6.0","18.7.0"],"last_affected":[],"package":"gitlab","purl":"pkg:bitnami/gitlab","source":"BIT-gitlab-2025-9222"}],"prev":{"headline":"Post SMTP \u003c= 3.4.1 - Missing Authorization to Authenticated (Subscriber+) Limited Plugin Option Update","id":"CVE-2025-9219"},"products":["GitLab"],"published":"2026-01-09","related":[{"cvss_score":10,"headline":"GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound","id":"CVE-2026-97229","kev_date_added":"2026-10-29","published":"2026-10-13"},{"cvss_score":10,"headline":"GitLab Community Edition and Enterprise Edition Path Traversal","id":"CVE-2026-85706","kev_date_added":"2026-09-11","published":"2026-09-12"},{"cvss_score":10,"headline":"GitLab Community and Enterprise Editions Improper Access Control","id":"CVE-2023-7028","kev_date_added":"2024-05-01","published":"2024-01-12"},{"cvss_score":10,"headline":"GitLab Community and Enterprise Editions Remote Code Execution","id":"CVE-2021-22205","kev_date_added":"2021-11-03","published":"2021-04-23"},{"cvss_score":6.8,"headline":"GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)","id":"CVE-2021-39935","kev_date_added":"2026-02-03","published":"2021-12-13"},{"cvss_score":6.8,"headline":"GitLab Server-Side Request Forgery (SSRF)","id":"CVE-2021-22175","kev_date_added":"2026-02-18","published":"2021-06-11"},{"cvss_score":10,"headline":"Integer Overflow or Wraparound in GitLab","id":"CVE-2026-110264","kev_date_added":null,"published":"2026-10-22"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-15","vendors":["GitLab"]},"summary":"An authenticated user can achieve stored cross-site scripting via GitLab Flavored Markdown, potentially leading to code execution or account takeover.","url":"https://insights.sbomify.com/CVE-2025-9222/"}