# CVE-2025-9265: API Authentication Bypass via Header Spoofing vulnerability in Kiloview NDI N30 Products

> Remote attackers can bypass authentication via header spoofing to perform administrative actions on Kiloview NDI N30 devices.

- **Severity:** Critical 10.0 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Oct 2025
- **Updated:** 14 Oct 2025
- **Also known as:** GHSA-cvx8-x87w-7x8c

## What is CVE-2025-9265?

CVE-2025-9265 is a critical authentication bypass vulnerability in Kiloview NDI, published on 13 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A broken authorization vulnerability in Kiloview NDI N30 allows a remote unauthenticated attacker to deactivate user verification, giving them access to state changing actions that should only be initiated by administratorsThis issue affects 

 Kiloview NDI N30

and was fixed in Firmware version later than  2.02.0246

Weakness: CWE-346 (Origin Validation Error), CWE-290 (Authentication Bypass by Spoofing), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2025-9265?


## How do I fix CVE-2025-9265?

No fix has been published for CVE-2025-9265 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-9265 being exploited?

There is no known exploitation of CVE-2025-9265 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-9265 and fix it if it is affected.

What it is: CVE-2025-9265 is a critical authentication bypass vulnerability in Kiloview NDI, published on 13 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-9265 in the wild and no public exploit code.

Affected product: Kiloview NDI. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-9265/ (Markdown: https://insights.sbomify.com/CVE-2025-9265/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-9265
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-9265
- OSV: https://osv.dev/vulnerability/CVE-2025-9265

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-9265/
Summaries are generated and may contain mistakes; the official description above is the record.
