{"answers":{"affected":"2 open source packages ship an affected version, including cipher-base. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9287 exists.","fix":"Upgrade cipher-base to 1.0.5 or later.","what":"CVE-2025-9287 is a critical vulnerability in browserify:cipher-base, published on 20 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-9287 and fix it if it is affected.\n\nWhat it is: CVE-2025-9287 is a critical vulnerability in browserify:cipher-base, published on 20 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9287 exists.\n\nAffected packages and fixed versions:\n- cipher-base (npm): affected all versions; fixed in 1.0.5\n- cipher-base (npm): affected all versions; fixed in 1.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-9287/ (Markdown: https://insights.sbomify.com/CVE-2025-9287/index.md)","id":"CVE-2025-9287","markdown":"https://insights.sbomify.com/CVE-2025-9287/index.md","name":"CVE-2025-9287","record":{"aliases":["CLSA-2026-1779670116","DEBIAN-CVE-2025-9287","DLA-4291-1","DSA-5986-1","GHSA-cpq7-6gpm-g9rc","ROOT-APP-NPM-CVE-2025-9287","UBUNTU-CVE-2025-9287","USN-7746-1","openSUSE-SU-2025:15484-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js crypto library","requires_auth":"none","summary":"Attackers can manipulate input data in the cipher-base library due to missing type checks, potentially altering cryptographic operations.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"harborist","cpe":[{"product":"cipher-base","vendor":"browserify"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:H/VA:H/SC:H/SI:H/SA:N","version":"4.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Improper Input Validation vulnerability in cipher-base allows Input Data Manipulation.This issue affects cipher-base: through 1.0.4.","ecosystems":["npm","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Missing type checks leading to hash rewind and passing on crafted data","id":"CVE-2025-9287","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"other","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Missing type checks leading to hash rewind and passing on crafted data","id":"CVE-2025-9288"},"packages":[{"ecosystem":"npm","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"cipher-base","purl":null,"source":"GHSA-cpq7-6gpm-g9rc"},{"ecosystem":"npm","fixed":["1.0.5"],"introduced":["0"],"last_affected":[],"package":"cipher-base","purl":"pkg:npm/cipher-base","source":"GHSA-cpq7-6gpm-g9rc"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["0.12.45-12.1"],"introduced":["0"],"last_affected":[],"package":"python-bqplot","purl":"pkg:rpm/opensuse/python-bqplot\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15484-1"}],"prev":{"headline":"Missing authorization in Appy Pie Connect for WooCommerce","id":"CVE-2025-9286"},"products":["browserify:cipher-base"],"published":"2025-08-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["browserify"]},"summary":"Attackers can manipulate input data in the cipher-base library due to missing type checks, potentially altering cryptographic operations.","url":"https://insights.sbomify.com/CVE-2025-9287/"}