{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9300 exists.","fix":"Apply the vendor's patch.","what":"CVE-2025-9300 is a medium-severity memory corruption vulnerability in saitoha libsixel, published on 21 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-9300 and fix it if it is affected.\n\nWhat it is: CVE-2025-9300 is a medium-severity memory corruption vulnerability in saitoha libsixel, published on 21 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9300 exists.\n\nAffected product: saitoha libsixel. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-9300/ (Markdown: https://insights.sbomify.com/CVE-2025-9300/index.md)","id":"CVE-2025-9300","markdown":"https://insights.sbomify.com/CVE-2025-9300/index.md","name":"CVE-2025-9300","record":{"aliases":["DEBIAN-CVE-2025-9300","GHSA-m23p-3g32-h722","UBUNTU-CVE-2025-9300","openSUSE-SU-2025:15526-1"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Sixel image library","requires_auth":"low_privilege","summary":"A stack-based buffer overflow in libsixel allows local attackers to execute arbitrary code or cause denial of service via crafted input.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"libsixel","vendor":"saitoha"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-121","name":"Stack-based Buffer Overflow"},{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"A vulnerability was found in saitoha libsixel up to 1.10.3. Affected by this issue is the function sixel_debug_print_palette of the file src/encoder.c of the component img2sixel. The manipulation results in stack-based buffer overflow. The attack must be initiated from a local position. The exploit has been made public and could be used. The patch is identified as 316c086e79d66b62c0c4bc66229ee894e4fdb7d1. Applying a patch is advised to resolve this issue.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"saitoha libsixel img2sixel encoder.c sixel_debug_print_palette stack-based overflow","id":"CVE-2025-9300","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2025"},"n_packages":1,"n_references":7,"next":{"headline":"cmake cmForEachCommand.cxx ReplayItems assertion","id":"CVE-2025-9301"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.10.5-2.1"],"introduced":["0"],"last_affected":[],"package":"libsixel","purl":"pkg:rpm/opensuse/libsixel\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15526-1"}],"prev":{"headline":"Tenda M3 getMasterPassengerAnalyseData formGetMasterPassengerAnalyseData stack-based overflow","id":"CVE-2025-9299"},"products":["libsixel"],"published":"2025-08-21","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2019-19635","kev_date_added":null,"published":"2019-12-08"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2019-19636","kev_date_added":null,"published":"2019-12-08"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2019-19637","kev_date_added":null,"published":"2019-12-08"},{"cvss_score":9.8,"headline":"Integer overflow in n/a","id":"CVE-2019-19638","kev_date_added":null,"published":"2019-12-08"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2022-27044","kev_date_added":null,"published":"2022-04-08"},{"cvss_score":8.8,"headline":"Use after free in n/a","id":"CVE-2022-27046","kev_date_added":null,"published":"2022-04-08"},{"cvss_score":8.8,"headline":"Memory corruption in n/a","id":"CVE-2020-21547","kev_date_added":null,"published":"2021-09-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-21","vendors":["saitoha"]},"summary":"A stack-based buffer overflow in libsixel allows local attackers to execute arbitrary code or cause denial of service via crafted input.","url":"https://insights.sbomify.com/CVE-2025-9300/"}