{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-9353 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2025-9353 yet. Limit exposure of the affected software until one is available.","what":"CVE-2025-9353 is a medium-severity cross-site scripting vulnerability in themifyme Themify Builder, published on 24 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-9353 and fix it if it is affected.\n\nWhat it is: CVE-2025-9353 is a medium-severity cross-site scripting vulnerability in themifyme Themify Builder, published on 24 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-9353 in the wild and no public exploit code.\n\nAffected product: themifyme Themify Builder. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-9353/ (Markdown: https://insights.sbomify.com/CVE-2025-9353/index.md)","id":"CVE-2025-9353","markdown":"https://insights.sbomify.com/CVE-2025-9353/index.md","name":"CVE-2025-9353","record":{"aliases":["GHSA-43wv-69rq-rx33"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Authenticated attackers with Contributor access can inject arbitrary scripts into pages via the Themify Builder plugin, affecting WordPress users.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Wordfence","cpe":[],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 7.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 7.6.9.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Themify Builder \u003c= 7.6.9 - Authenticated (Contributor+) Stored Cross-Site Scripting","id":"CVE-2025-9353","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2025"},"n_packages":0,"n_references":7,"next":{"headline":"Linksys RE6250/RE6300/RE6350/RE6500/RE7000/RE9000 scheduleAdd stack-based overflow","id":"CVE-2025-9355"},"packages":[],"prev":{"headline":"Pronamic Google Maps \u003c= 2.4.1 - Authenticated (Contributor+) Stored Cross-Site Scripting","id":"CVE-2025-9352"},"products":["Themify Builder"],"published":"2025-09-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-04-08","vendors":["themifyme"]},"summary":"Authenticated attackers with Contributor access can inject arbitrary scripts into pages via the Themify Builder plugin, affecting WordPress users.","url":"https://insights.sbomify.com/CVE-2025-9353/"}