CVE-2025-9467 Possibility to bypass file upload validation on the server-side
Attackers can bypass server-side file upload validation in Vaadin applications using the start listener, potentially uploading malicious files.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-9467?
CVE-2025-9467 is a medium-severity vulnerability in vaadin framework, published on 4 Sep 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
When the Vaadin Upload's start listener is used to validate metadata about an incoming upload, it is possible to bypass the upload validation.
Users of affected versions should apply the following mitigation or upgrade. Releases that have fixed this issue include:
Product version Vaadin 7.0.0 - 7.7.47 Vaadin 8.0.0 - 8.28.1 Vaadin 14.0.0 - 14.13.0 Vaadin 23.0.0 - 23.6.1 Vaadin 24.0.0 - 24.7.6
Mitigation Upgrade to 7.7.48 Upgrade to 8.28.2 Upgrade to 14.13.1 Upgrade to 23.6.2 Upgrade to 24.7.7 or newer
Please note that Vaadin versions 10-13 and 15-22 are no longer supported and you should update either to the latest 14, 23, 24 version.
Artifacts Maven coordinatesVulnerable versionsFixed versioncom.vaadin:vaadin-server 7.0.0 - 7.7.47 ≥7.7.48 com.vaadin:vaadin-server 8.0.0 - 8.28.1 ≥8.28.2 com.vaadin:vaadin 14.0.0 - 14.13.0 ≥14.13.1 com.vaadin:vaadin23.0.0 - 23.6.1 ≥23.6.2 com.vaadin:vaadin24.0.0 - 24.7.6 ≥24.7.7com.vaadin:vaadin-upload-flow 2.0.0 - 14.13.0 ≥14.13.1 com.vaadin:vaadin-upload-flow 23.0.0 - 23.6.1 ≥23.6.2 com.vaadin:vaadin-upload-flow 24.0.0 - 24.7.6 ≥24.7.7
Weakness: CWE-20
Which versions are affected by CVE-2025-9467?
4 open source packages ship an affected version, including com.vaadin:vaadin-server.
| Package | Affected | Fixed in |
|---|---|---|
com.vaadin:vaadin-server Maven | From 7.0.0 | 7.7.48 |
com.vaadin:vaadin-server Maven | From 7.0.0 | 7.7.48 |
com.vaadin:vaadin-server Maven | From 8.0.0 | 8.28.2 |
com.vaadin:vaadin-server Maven | From 8.0.0 | 8.28.2 |
How do I fix CVE-2025-9467?
Upgrade com.vaadin:vaadin-server to a fixed version for your release line: 7.7.48 or 8.28.2.
Is CVE-2025-9467 being exploited?
There is no known exploitation of CVE-2025-9467 in the wild and no public exploit code.
Sources
Also known as GHSA-9gfh-4fwj-w3rj.