# CVE-2025-9606: Portabilis i-Educar agenda_preferencias.php sql injection

> Remote attackers can exploit SQL injection in the agenda preferences module to read or modify database contents.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Aug 2025
- **Updated:** 15 Sep 2026
- **Also known as:** GHSA-48c3-rv3g-4gwm

## What is CVE-2025-9606?

CVE-2025-9606 is a medium-severity SQL injection vulnerability in Portabilis I-Educar, published on 29 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was detected in Portabilis i-Educar up to 2.10. Affected by this vulnerability is an unknown functionality of the file /intranet/agenda_preferencias.php. Performing a manipulation of the argument cod_agenda results in sql injection. The attack may be initiated remotely. The exploit is now public and may be used. Upgrading to version 2.12 addresses this issue. Upgrading the affected component is advised. The vendor confirms: "The reported attack vector was tested against the corrected code, and the previously described SQL Injection behavior could no longer be reproduced."

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2025-9606?

It affects 1 product.


Products: Portabilis I-Educar.

## How do I fix CVE-2025-9606?

No fix has been published for CVE-2025-9606 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-9606 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9606 exists.

## Other vulnerabilities in Portabilis I-Educar

- [CVE-2024-45059](https://insights.sbomify.com/CVE-2024-45059/): Authenticated SQL Injection in i-Educar (high 8.8)
- [CVE-2024-48325](https://insights.sbomify.com/CVE-2024-48325/): SQL injection in n/a (high 8.1)
- [CVE-2024-45058](https://insights.sbomify.com/CVE-2024-45058/): Privilege escalation in i-Educar (high 8.1)
- [CVE-2025-65022](https://insights.sbomify.com/CVE-2025-65022/): i-Educar Authenticated Time-based SQL Injection in `agenda.php` (high 7.2)
- [CVE-2025-65023](https://insights.sbomify.com/CVE-2025-65023/): i-Educar Authenticated Time-based SQL Injection in `funcionario_vinculo_cad.php` (high 7.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-9606 and fix it if it is affected.

What it is: CVE-2025-9606 is a medium-severity SQL injection vulnerability in Portabilis I-Educar, published on 29 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9606 exists.

Affected product: Portabilis I-Educar. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-9606/ (Markdown: https://insights.sbomify.com/CVE-2025-9606/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-9606
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-9606
- OSV: https://osv.dev/vulnerability/CVE-2025-9606

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-9606/
Summaries are generated and may contain mistakes; the official description above is the record.
