CVE-2025-9624 OpenSearch 3.2.0 - Nested Boolean/Disjunction asymmetric DoS

High 8.3 Published Updated

Attackers can cause denial of service in OpenSearch by submitting complex query_string inputs, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-9624?

CVE-2025-9624 is a high-severity denial of service vulnerability in OpenSearch, published on 25 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability in OpenSearch allows attackers to cause Denial of Service (DoS) by submitting complex query_string inputs.

This issue affects all OpenSearch versions between 3.0.0 and < 3.3.0 and OpenSearch < 2.19.4.

Weakness: CWE-674

Which versions are affected by CVE-2025-9624?

4 open source packages ship an affected version, including org.opensearch:opensearch-common. It affects 1 product.

PackageAffectedFixed in
org.opensearch:opensearch-common MavenAll versions2.19.4
org.opensearch:opensearch-common MavenAll versions2.19.4
org.opensearch:opensearch-common MavenFrom 3.0.03.3.0
org.opensearch:opensearch-common MavenFrom 3.0.03.3.0

Products include Amazon Opensearch.

How do I fix CVE-2025-9624?

Upgrade org.opensearch:opensearch-common to a fixed version for your release line: 2.19.4 or 3.3.0.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-9624 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9624 exists.

Sources

Also known as GHSA-mw3v-mmfw-3x2g, MINI-hw5q-jccc-cj85, MINI-m6mx-5c6p-xgfr, UBUNTU-CVE-2025-9624.

Is CVE-2025-9624 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free