# CVE-2025-9624: OpenSearch 3.2.0 - Nested Boolean/Disjunction asymmetric DoS

> Attackers can cause denial of service in OpenSearch by submitting complex query_string inputs, requiring an upgrade to patched versions.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Nov 2025
- **Updated:** 15 Dec 2025
- **Also known as:** GHSA-mw3v-mmfw-3x2g, MINI-hw5q-jccc-cj85, MINI-m6mx-5c6p-xgfr, UBUNTU-CVE-2025-9624

## What is CVE-2025-9624?

CVE-2025-9624 is a high-severity denial of service vulnerability in OpenSearch, published on 25 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability in OpenSearch allows attackers to cause Denial of Service (DoS) by submitting complex query_string inputs.

This issue affects all OpenSearch versions between 3.0.0 and < 3.3.0 and OpenSearch < 2.19.4.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2025-9624?

4 open source packages ship an affected version, including org.opensearch:opensearch-common. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opensearch:opensearch-common` | Maven | All versions | 2.19.4 |
| `org.opensearch:opensearch-common` | Maven | All versions | 2.19.4 |
| `org.opensearch:opensearch-common` | Maven | From 3.0.0 | 3.3.0 |
| `org.opensearch:opensearch-common` | Maven | From 3.0.0 | 3.3.0 |

Products: Amazon Opensearch.

## How do I fix CVE-2025-9624?

Upgrade org.opensearch:opensearch-common to a fixed version for your release line: 2.19.4 or 3.3.0.

## Is CVE-2025-9624 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9624 exists.

## Other vulnerabilities in OpenSearch

- [CVE-2022-31115](https://insights.sbomify.com/CVE-2022-31115/): Unsafe YAML deserialization in opensearch-ruby (high 8.8)
- [CVE-2022-35980](https://insights.sbomify.com/CVE-2022-35980/): OpenSearch vulnerable to Improper Authorization of Index Containing Sensitive Information (high 7.5)
- [CVE-2022-41918](https://insights.sbomify.com/CVE-2022-41918/): Issue with fine-grained access control of indices backing data streams (medium 6.3)
- [CVE-2023-23933](https://insights.sbomify.com/CVE-2023-23933/): Issue in Anomaly Detection with document and field level rules in numerical feature aggregations (medium 5.7)
- [CVE-2023-23613](https://insights.sbomify.com/CVE-2023-23613/): Field-level security issue with .keyword fields in OpenSearch (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-9624 and fix it if it is affected.

What it is: CVE-2025-9624 is a high-severity denial of service vulnerability in OpenSearch, published on 25 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9624 exists.

Affected packages and fixed versions:
- org.opensearch:opensearch-common (Maven): affected all versions; fixed in 2.19.4
- org.opensearch:opensearch-common (Maven): affected all versions; fixed in 2.19.4
- org.opensearch:opensearch-common (Maven): affected from 3.0.0; fixed in 3.3.0
- org.opensearch:opensearch-common (Maven): affected from 3.0.0; fixed in 3.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-9624/ (Markdown: https://insights.sbomify.com/CVE-2025-9624/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-9624
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-9624
- OSV: https://osv.dev/vulnerability/CVE-2025-9624

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-9624/
Summaries are generated and may contain mistakes; the official description above is the record.
