# CVE-2025-9636: Cross-Origin Opener Policy Vulnerability in pgAdmin 4

> Attackers can bypass Cross-Origin Opener Policy to manipulate OAuth flows, leading to unauthorized account access and privilege escalation in pgAdmin 4.

- **Severity:** High 7.9 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Sep 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-6859-2qxq-ffv2, PYSEC-2026-1769, SUSE-SU-2025:03625-1, SUSE-SU-2026:0232-1, openSUSE-SU-2025:15612-1

## What is CVE-2025-9636?

CVE-2025-9636 is a high-severity vulnerability in pgadmin.org pgAdmin 4, published on 4 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

pgAdmin <= 9.7 is affected by a  Cross-Origin Opener Policy (COOP) vulnerability. This vulnerability allows an attacker to manipulate the OAuth flow, potentially leading to unauthorised account access, account takeover, data breaches, and privilege escalation.

Weakness: CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2025-9636?

3 open source packages ship an affected version, including pgadmin4. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pgadmin4` | PyPI | All versions | 9.8 |
| `pgadmin4` | PyPI | All versions | 9.8 |
| `pgadmin4` | PyPI | All versions | 9.8 |
| `pgadmin4` | SUSE:Linux Enterprise High Performance Computing 15 SP4-ESPOS | All versions | 4.30-150300.3.24.1 |
| `pgadmin4` | SUSE:Linux Enterprise High Performance Computing 15 SP4-LTSS | All versions | 4.30-150300.3.24.1 |
| `pgadmin4` | SUSE:Linux Enterprise High Performance Computing 15 SP5-ESPOS | All versions | 4.30-150300.3.24.1 |
| `pgadmin4` | SUSE:Linux Enterprise High Performance Computing 15 SP5-LTSS | All versions | 4.30-150300.3.24.1 |
| `pgadmin4` | SUSE:Linux Enterprise Module for Python 3 15 SP6 | All versions | 8.5-150600.3.15.1 |
| `pgadmin4` | SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 4.30-150300.3.24.1 |
| `pgadmin4` | SUSE:Linux Enterprise Module for Python 3 15 SP7 | All versions | 8.5-150600.3.15.1 |
| `pgadmin4` | SUSE:Linux Enterprise Server 15 SP4-LTSS | All versions | 4.30-150300.3.24.1 |
| `pgadmin4` | SUSE:Linux Enterprise Server 15 SP5-LTSS | All versions | 4.30-150300.3.24.1 |
| `pgadmin4` | SUSE:Linux Enterprise Server 15 SP6-LTSS | All versions | 4.30-150300.3.24.1 |
| `pgadmin4` | SUSE:Linux Enterprise Server for SAP Applications 15 SP4 | All versions | 4.30-150300.3.24.1 |
| `pgadmin4` | SUSE:Linux Enterprise Server for SAP Applications 15 SP5 | All versions | 4.30-150300.3.24.1 |
| `pgadmin4` | SUSE:Linux Enterprise Server for SAP Applications 15 SP6 | All versions | 4.30-150300.3.24.1 |
| `pgadmin4` | openSUSE:Leap 15.6 | All versions | 8.5-150600.3.15.1 |
| `pgadmin4` | openSUSE:Tumbleweed | All versions | 9.8-1.1 |

Products: Pgadmin Pgadmin 4.

## How do I fix CVE-2025-9636?

Upgrade pgadmin4 to 9.8 or later.

## Is CVE-2025-9636 being exploited?

There is no known exploitation of CVE-2025-9636 in the wild and no public exploit code.

## Other vulnerabilities in pgadmin.org pgAdmin 4

- [CVE-2025-2945](https://insights.sbomify.com/CVE-2025-2945/): pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment (critical 9.9)
- [CVE-2024-9014](https://insights.sbomify.com/CVE-2024-9014/): OAuth2 client id and secret exposed through the web browser in pgAdmin 4 (critical 9.9)
- [CVE-2026-12046](https://insights.sbomify.com/CVE-2026-12046/): Deserialization in pgAdmin 4 (critical 9.5)
- [CVE-2026-17351](https://insights.sbomify.com/CVE-2026-17351/): SQL injection in pgAdmin 4 (critical 9.4)
- [CVE-2026-17566](https://insights.sbomify.com/CVE-2026-17566/): Command injection in pgAdmin 4 (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-9636 and fix it if it is affected.

What it is: CVE-2025-9636 is a high-severity vulnerability in pgadmin.org pgAdmin 4, published on 4 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-9636 in the wild and no public exploit code.

Affected packages and fixed versions:
- pgadmin4 (PyPI): affected all versions; fixed in 9.8
- pgadmin4 (PyPI): affected all versions; fixed in 9.8
- pgadmin4 (PyPI): affected all versions; fixed in 9.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-9636/ (Markdown: https://insights.sbomify.com/CVE-2025-9636/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-9636
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-9636
- OSV: https://osv.dev/vulnerability/CVE-2025-9636

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-9636/
Summaries are generated and may contain mistakes; the official description above is the record.
