CVE-2025-9642 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

High 8.7 Published Updated

An attacker can inject malicious content via cross-site scripting to potentially take over user accounts in GitLab.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-9642?

CVE-2025-9642 is a high-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 26 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions from 14.10 before 18.2.7, 18.3 before 18.3.3, and 18.4 before 18.4.1 that could allow an attacker to inject malicious content that may lead to account takeover.

Weakness: CWE-79

Which versions are affected by CVE-2025-9642?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 14.10.018.2.7, 18.3.3, 18.4.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-9642?

Upgrade gitlab to a fixed version for your release line: 18.2.7, 18.3.3 or 18.4.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-9642 being exploited?

There is no known exploitation of CVE-2025-9642 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-9642, GHSA-2g5p-9p7q-76jj.

Is CVE-2025-9642 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free