{"answers":{"affected":"2 open source packages ship an affected version, including @aiondadotcom/mcp-ssh.","exploited":"There is no known exploitation of CVE-2025-9654 in the wild and no public exploit code.","fix":"Upgrade @aiondadotcom/mcp-ssh to 1.1.0 or later.","what":"CVE-2025-9654 is a medium-severity command injection vulnerability in AiondaDotCom mcp-ssh, published on 29 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-9654 and fix it if it is affected.\n\nWhat it is: CVE-2025-9654 is a medium-severity command injection vulnerability in AiondaDotCom mcp-ssh, published on 29 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-9654 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @aiondadotcom/mcp-ssh (npm): affected all versions; fixed in 1.1.0\n- @aiondadotcom/mcp-ssh (npm): affected all versions; fixed in 1.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-9654/ (Markdown: https://insights.sbomify.com/CVE-2025-9654/index.md)","id":"CVE-2025-9654","markdown":"https://insights.sbomify.com/CVE-2025-9654/index.md","name":"CVE-2025-9654","record":{"aliases":["GHSA-694p-3fxc-m92h"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"MCP SSH library","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary commands via command injection in the mcp-ssh library, requiring an upgrade to secure the system.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X","version":"4.0"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"A security flaw has been discovered in AiondaDotCom mcp-ssh up to 1.0.3. Affected by this issue is some unknown functionality of the file server-simple.mjs. Performing manipulation results in command injection. The attack can be initiated remotely. Upgrading to version 1.0.4 and 1.1.0 can resolve this issue. The patch is named cd2566a948b696501abfa6c6b03462cac5fb43d8. It is advisable to upgrade the affected component.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AiondaDotCom mcp-ssh server-simple.mjs command injection","id":"CVE-2025-9654","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":2,"n_references":5,"next":{"headline":"O2OA Personal Profile person cross site scripting","id":"CVE-2025-9655"},"packages":[{"ecosystem":"npm","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"@aiondadotcom/mcp-ssh","purl":null,"source":"GHSA-694p-3fxc-m92h"},{"ecosystem":"npm","fixed":["1.1.0"],"introduced":["0"],"last_affected":[],"package":"@aiondadotcom/mcp-ssh","purl":"pkg:npm/%40aiondadotcom/mcp-ssh","source":"GHSA-694p-3fxc-m92h"}],"prev":{"headline":"Portabilis i-Educar Cadastrar projeto educar_projeto_cad.php cross site scripting","id":"CVE-2025-9653"},"products":["mcp-ssh"],"published":"2025-08-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-08-29","vendors":["AiondaDotCom"]},"summary":"Remote attackers can execute arbitrary commands via command injection in the mcp-ssh library, requiring an upgrade to secure the system.","url":"https://insights.sbomify.com/CVE-2025-9654/"}