# CVE-2025-9654: AiondaDotCom mcp-ssh server-simple.mjs command injection

> Remote attackers can execute arbitrary commands via command injection in the mcp-ssh library, requiring an upgrade to secure the system.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Aug 2025
- **Updated:** 29 Aug 2025
- **Also known as:** GHSA-694p-3fxc-m92h

## What is CVE-2025-9654?

CVE-2025-9654 is a medium-severity command injection vulnerability in AiondaDotCom mcp-ssh, published on 29 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A security flaw has been discovered in AiondaDotCom mcp-ssh up to 1.0.3. Affected by this issue is some unknown functionality of the file server-simple.mjs. Performing manipulation results in command injection. The attack can be initiated remotely. Upgrading to version 1.0.4 and 1.1.0 can resolve this issue. The patch is named cd2566a948b696501abfa6c6b03462cac5fb43d8. It is advisable to upgrade the affected component.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2025-9654?

2 open source packages ship an affected version, including @aiondadotcom/mcp-ssh.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@aiondadotcom/mcp-ssh` | npm | All versions | 1.1.0 |
| `@aiondadotcom/mcp-ssh` | npm | All versions | 1.1.0 |

## How do I fix CVE-2025-9654?

Upgrade @aiondadotcom/mcp-ssh to 1.1.0 or later.

## Is CVE-2025-9654 being exploited?

There is no known exploitation of CVE-2025-9654 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-9654 and fix it if it is affected.

What it is: CVE-2025-9654 is a medium-severity command injection vulnerability in AiondaDotCom mcp-ssh, published on 29 Aug 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-9654 in the wild and no public exploit code.

Affected packages and fixed versions:
- @aiondadotcom/mcp-ssh (npm): affected all versions; fixed in 1.1.0
- @aiondadotcom/mcp-ssh (npm): affected all versions; fixed in 1.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-9654/ (Markdown: https://insights.sbomify.com/CVE-2025-9654/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-9654
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-9654
- OSV: https://osv.dev/vulnerability/CVE-2025-9654

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-9654/
Summaries are generated and may contain mistakes; the official description above is the record.
