{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-9688 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2025-9688 is a low-severity vulnerability in Mupen64Plus, published on 30 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-9688 and fix it if it is affected.\n\nWhat it is: CVE-2025-9688 is a low-severity vulnerability in Mupen64Plus, published on 30 Aug 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2025-9688 in the wild and no public exploit code.\n\nAffected product: Mupen64Plus. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-9688/ (Markdown: https://insights.sbomify.com/CVE-2025-9688/index.md)","id":"CVE-2025-9688","markdown":"https://insights.sbomify.com/CVE-2025-9688/index.md","name":"CVE-2025-9688","record":{"aliases":["DEBIAN-CVE-2025-9688","GHSA-449c-3xhq-m2q6","UBUNTU-CVE-2025-9688","openSUSE-SU-2025:15513-1"],"analysis":{"component_type":"desktop_application","fix_type":"patch","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Nintendo 64 emulator","requires_auth":"none","summary":"An integer overflow in Mupen64Plus allows remote attackers to potentially execute code or cause denial of service via complex attacks.","user_interaction":"required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-190","name":"Integer Overflow or Wraparound"},{"id":"CWE-189","name":null}],"description":"A security vulnerability has been detected in Mupen64Plus up to 2.6.0. The affected element is the function write_is_viewer of the file src/device/cart/is_viewer.c. The manipulation leads to integer overflow. It is possible to initiate the attack remotely. The attack is considered to have high complexity. The exploitability is described as difficult. The exploit has been disclosed publicly and may be used. The identifier of the patch is 3984137fc0c44110f1ef876adb008885b05a6e18. To fix this issue, it is recommended to deploy a patch.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mupen64Plus is_viewer.c write_is_viewer integer overflow","id":"CVE-2025-9688","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2025"},"n_packages":1,"n_references":5,"next":{"headline":"SourceCodester Advanced School Management System item_select sql injection","id":"CVE-2025-9689"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["2.6.0-2.1"],"introduced":["0"],"last_affected":[],"package":"mupen64plus","purl":"pkg:rpm/opensuse/mupen64plus\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2025:15513-1"}],"prev":{"headline":"Portabilis i-Educar processamentoApi improper authorization","id":"CVE-2025-9687"},"products":["Mupen64Plus"],"published":"2025-08-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-02","vendors":["n/a"]},"summary":"An integer overflow in Mupen64Plus allows remote attackers to potentially execute code or cause denial of service via complex attacks.","url":"https://insights.sbomify.com/CVE-2025-9688/"}