# CVE-2025-9708: Kubernetes C# Client: improper certificate validation in custom CA mode may lead to man-in-the-middle attacks

> Attackers can intercept Kubernetes API traffic via man-in-the-middle attacks due to improper certificate validation in the C# client's custom CA mode.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Sep 2025
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-w7r3-mgwf-4mqq

## What is CVE-2025-9708?

CVE-2025-9708 is a medium-severity vulnerability in Kubernetes CSharp Client, published on 16 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability exists in the Kubernetes C# client where the certificate validation logic accepts properly constructed certificates from any Certificate Authority (CA) without properly verifying the trust chain. This flaw allows a malicious actor to present a forged certificate and potentially intercept or manipulate communication with the Kubernetes API server, leading to possible man-in-the-middle attacks and API impersonation.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2025-9708?

2 open source packages ship an affected version, including KubernetesClient.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `KubernetesClient` | NuGet | All versions | 17.0.14 |
| `KubernetesClient` | NuGet | All versions | 17.0.14 |

## How do I fix CVE-2025-9708?

Upgrade KubernetesClient to 17.0.14 or later.

## Is CVE-2025-9708 being exploited?

There is no known exploitation of CVE-2025-9708 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-9708 and fix it if it is affected.

What it is: CVE-2025-9708 is a medium-severity vulnerability in Kubernetes CSharp Client, published on 16 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-9708 in the wild and no public exploit code.

Affected packages and fixed versions:
- KubernetesClient (NuGet): affected all versions; fixed in 17.0.14
- KubernetesClient (NuGet): affected all versions; fixed in 17.0.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-9708/ (Markdown: https://insights.sbomify.com/CVE-2025-9708/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-9708
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-9708
- OSV: https://osv.dev/vulnerability/CVE-2025-9708

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-9708/
Summaries are generated and may contain mistakes; the official description above is the record.
