# CVE-2025-9725: Cudy LT500E Web shadow hard-coded password

> Local attackers can exploit a hard-coded default password in the web interface to gain administrative access to the Cudy LT500E router.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 31 Aug 2025
- **Updated:** 2 Sep 2025
- **Also known as:** GHSA-whjv-65hm-x47g

## What is CVE-2025-9725?

CVE-2025-9725 is a low-severity vulnerability in Cudy LT500E, published on 31 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability was identified in Cudy LT500E up to 2.3.12. Affected is an unknown function of the file /squashfs-root/etc/shadow of the component Web Interface. The manipulation leads to use of hard-coded password. The attack must be carried out locally. The attack's complexity is rated as high. The exploitability is told to be difficult. The exploit is publicly available and might be used. Upgrading to version 2.3.13 is able to address this issue. It is recommended to upgrade the affected component. The vendor explains: "[T]he firmware does store a default password of 'admin'. This password has been deprecated since LT500E firmware version 2.3.13 and is no longer used. The LT500E does not have an administrator password set by default; a new password (at least 8 characters ) must be manually created upon first login the web management page."

Weakness: CWE-259 (Use of Hard-coded Password), CWE-798 (Use of Hard-coded Credentials), CWE-255

## Which versions are affected by CVE-2025-9725?

It affects 1 product.


Products: Cudy Lt500e Firmware.

## How do I fix CVE-2025-9725?

No fix has been published for CVE-2025-9725 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-9725 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9725 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-9725 and fix it if it is affected.

What it is: CVE-2025-9725 is a low-severity vulnerability in Cudy LT500E, published on 31 Aug 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9725 exists.

Affected product: Cudy LT500E. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-9725/ (Markdown: https://insights.sbomify.com/CVE-2025-9725/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-9725
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-9725
- OSV: https://osv.dev/vulnerability/CVE-2025-9725

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-9725/
Summaries are generated and may contain mistakes; the official description above is the record.
