# CVE-2025-9747: Koillection csrf_protection_controller.js cross-site request forgery


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 31 Aug 2025
- **Updated:** 2 Sep 2025

## What is CVE-2025-9747?

CVE-2025-9747 is a medium-severity vulnerability in Koillection, published on 31 Aug 2025. 

### Official description

A vulnerability has been found in Koillection up to 1.6.18. Affected is an unknown function of the file assets/controllers/csrf_protection_controller.js. Such manipulation leads to cross-site request forgery. The attack can be executed remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.7.0 is able to address this issue. The name of the patch is 9ab8562d3f1e953da93fed63f9ee802c7ea26a9a. It is suggested to upgrade the affected component. The vendor explains: "I ended up switching to a newer CSRF handling using stateless token."

Weakness: CWE-862 (Missing Authorization), CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-9747?

It affects 1 product.


Products: Benjaminjonard Koillection.

## How do I fix CVE-2025-9747?

No fix has been published for CVE-2025-9747 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-9747 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9747 exists.

## Other vulnerabilities in Koillection

- [CVE-2025-29746](https://insights.sbomify.com/CVE-2025-29746/): Koillection Cross Site Scripting vulnerability (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-9747 and fix it if it is affected.

What it is: CVE-2025-9747 is a medium-severity vulnerability in Koillection, published on 31 Aug 2025. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9747 exists.

Affected product: Koillection. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-9747/ (Markdown: https://insights.sbomify.com/CVE-2025-9747/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-9747
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-9747
- OSV: https://osv.dev/vulnerability/CVE-2025-9747

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-9747/
Summaries are generated and may contain mistakes; the official description above is the record.
