CVE-2025-9796 thinkgem JeeSite EncodeUtils.java decodeUrl2 cross site scripting

Medium 5.1 Published Updated

Remote attackers can execute arbitrary scripts via cross-site scripting in the decodeUrl2 function of the JeeSite web application.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-9796?

CVE-2025-9796 is a medium-severity cross-site scripting vulnerability in thinkgem JeeSite, published on 1 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability was found in thinkgem JeeSite up to 5.12.1. This affects the function decodeUrl2 of the file common/src/main/java/com/jeesite/common/codec/EncodeUtils.java. The manipulation results in cross site scripting. It is possible to launch the attack remotely. The exploit has been made public and could be used. Upgrading to version 5.13.0 mitigates this issue. The patch is identified as 63773c97a56bdb3649510e83b66c16db4754965b. Upgrading the affected component is recommended.

Weakness: CWE-94, CWE-79

Which versions are affected by CVE-2025-9796?

It affects 1 product.

Products include Jeesite Jeesite.

How do I fix CVE-2025-9796?

No fix has been published for CVE-2025-9796 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-9796 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9796 exists.

Sources

Also known as GHSA-66x5-jrc5-2whj.

Is CVE-2025-9796 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free