# CVE-2025-9796: thinkgem JeeSite EncodeUtils.java decodeUrl2 cross site scripting

> Remote attackers can execute arbitrary scripts via cross-site scripting in the decodeUrl2 function of the JeeSite web application.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 1 Sep 2025
- **Updated:** 2 Sep 2025
- **Also known as:** GHSA-66x5-jrc5-2whj

## What is CVE-2025-9796?

CVE-2025-9796 is a medium-severity cross-site scripting vulnerability in thinkgem JeeSite, published on 1 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was found in thinkgem JeeSite up to 5.12.1. This affects the function decodeUrl2 of the file common/src/main/java/com/jeesite/common/codec/EncodeUtils.java. The manipulation results in cross site scripting. It is possible to launch the attack remotely. The exploit has been made public and could be used. Upgrading to version 5.13.0 mitigates this issue. The patch is identified as 63773c97a56bdb3649510e83b66c16db4754965b. Upgrading the affected component is recommended.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-9796?

It affects 1 product.


Products: Jeesite Jeesite.

## How do I fix CVE-2025-9796?

No fix has been published for CVE-2025-9796 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-9796 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9796 exists.

## Other vulnerabilities in thinkgem JeeSite

- [CVE-2023-34601](https://insights.sbomify.com/CVE-2023-34601/): SQL injection in n/a (critical 9.8)
- [CVE-2020-19229](https://insights.sbomify.com/CVE-2020-19229/): Deserialization in n/a (critical 9.8)
- [CVE-2024-8112](https://insights.sbomify.com/CVE-2024-8112/): thinkgem JeeSite Cookie login cross site scripting (medium 6.9)
- [CVE-2019-1010201](https://insights.sbomify.com/CVE-2019-1010201/): SQL injection in Jeesite (medium 6.5)
- [CVE-2019-1010202](https://insights.sbomify.com/CVE-2019-1010202/): XML external entity in Jeesite (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-9796 and fix it if it is affected.

What it is: CVE-2025-9796 is a medium-severity cross-site scripting vulnerability in thinkgem JeeSite, published on 1 Sep 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9796 exists.

Affected product: thinkgem JeeSite. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-9796/ (Markdown: https://insights.sbomify.com/CVE-2025-9796/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-9796
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-9796
- OSV: https://osv.dev/vulnerability/CVE-2025-9796

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-9796/
Summaries are generated and may contain mistakes; the official description above is the record.
