{"answers":{"affected":"2 open source packages ship an affected version, including jsondiffpatch.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9910 exists.","fix":"Upgrade jsondiffpatch to 0.7.2 or later.","what":"CVE-2025-9910 is a low-severity cross-site scripting vulnerability in jsondiffpatch, published on 11 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-9910 and fix it if it is affected.\n\nWhat it is: CVE-2025-9910 is a low-severity cross-site scripting vulnerability in jsondiffpatch, published on 11 Sep 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9910 exists.\n\nAffected packages and fixed versions:\n- jsondiffpatch (npm): affected all versions; fixed in 0.7.2\n- jsondiffpatch (npm): affected all versions; fixed in 0.7.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-9910/ (Markdown: https://insights.sbomify.com/CVE-2025-9910/index.md)","id":"CVE-2025-9910","markdown":"https://insights.sbomify.com/CVE-2025-9910/index.md","name":"CVE-2025-9910","record":{"aliases":["CLEANSTART-2026-OP77740","ECHO-a209-1045-04e4","GHSA-33vc-wfww-vjfv","MINI-4hjm-r75h-43w8","MINI-5vcf-2p87-rmx8","MINI-8x9p-573x-mjmf","MINI-9rjc-989r-c698","MINI-f3cj-33w9-qff9","MINI-hc79-xgh8-j74q","MINI-p985-j29q-xwm6","MINI-rr7h-4j8f-r9xf","ROOT-APP-NPM-CVE-2025-9910"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript diff library","requires_auth":"none","summary":"An attacker can inject malicious scripts via HTML payloads in jsondiffpatch, potentially leading to code execution on websites using the built-in HTML formatter.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"snyk","cpe":[],"cvss":{"score":2.3,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Versions of the package jsondiffpatch before 0.7.2 are vulnerable to Cross-site Scripting (XSS) via HtmlFormatter::nodeBegin. An attacker can inject malicious scripts into HTML payloads that may lead to code execution if untrusted payloads were used as source for the diff, and the result renderer using the built-in html formatter on a private website.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"jsondiffpatch is vulnerable to Cross-site Scripting (XSS) via HtmlFormatter::nodeBegin","id":"CVE-2025-9910","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":6,"next":{"headline":"A local privilege escalation vulnerability in Nokia SR Linux","id":"CVE-2025-9912"},"packages":[{"ecosystem":"npm","fixed":["0.7.2"],"introduced":["0"],"last_affected":[],"package":"jsondiffpatch","purl":null,"source":"GHSA-33vc-wfww-vjfv"},{"ecosystem":"npm","fixed":["0.7.2"],"introduced":["0"],"last_affected":[],"package":"jsondiffpatch","purl":"pkg:npm/jsondiffpatch","source":"GHSA-33vc-wfww-vjfv"}],"prev":{"headline":"Aap-gateway: improper path validation in gateway allows credential exfiltration","id":"CVE-2025-9909"},"products":["jsondiffpatch","org.webjars.bower:jsondiffpatch","org.webjars.npm:jsondiffpatch"],"published":"2025-09-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-09-11","vendors":["n/a"]},"summary":"An attacker can inject malicious scripts via HTML payloads in jsondiffpatch, potentially leading to code execution on websites using the built-in HTML formatter.","url":"https://insights.sbomify.com/CVE-2025-9910/"}