CVE-2025-9957 Incorrect Authorization in GitLab

Low 2.7 Published Updated

Authenticated project owners can bypass group fork prevention settings due to improper authorization checks in GitLab.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-9957?

CVE-2025-9957 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 22 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 11.2 before 18.9.6, 18.10 before 18.10.4, and 18.11 before 18.11.1 that under certain conditions could have allowed an authenticated user with project owner permissions to bypass group fork prevention settings due to improper authorization checks.

Weakness: CWE-863

Which versions are affected by CVE-2025-9957?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 11.2.018.9.6, 18.10.4, 18.11.1

Products include Gitlab Gitlab.

How do I fix CVE-2025-9957?

Upgrade gitlab to a fixed version for your release line: 18.9.6, 18.10.4 or 18.11.1.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2025-9957 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9957 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2025-9957, GHSA-6gww-qgc8-r365, UBUNTU-CVE-2025-9957.

Is CVE-2025-9957 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free