# CVE-2025-9957: Incorrect Authorization in GitLab

> Authenticated project owners can bypass group fork prevention settings due to improper authorization checks in GitLab.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Apr 2026
- **Updated:** 22 Apr 2026
- **Also known as:** BIT-gitlab-2025-9957, GHSA-6gww-qgc8-r365, UBUNTU-CVE-2025-9957

## What is CVE-2025-9957?

CVE-2025-9957 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 22 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

GitLab has remediated an issue in GitLab CE/EE affecting all versions from 11.2 before 18.9.6, 18.10 before 18.10.4, and 18.11 before 18.11.1 that under certain conditions could have allowed an authenticated user with project owner permissions to bypass group fork prevention settings due to improper authorization checks.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-9957?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 11.2.0 | 18.9.6, 18.10.4, 18.11.1 |

Products: Gitlab Gitlab.

## How do I fix CVE-2025-9957?

Upgrade gitlab to a fixed version for your release line: 18.9.6, 18.10.4 or 18.11.1.

## Is CVE-2025-9957 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9957 exists.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-9957 and fix it if it is affected.

What it is: CVE-2025-9957 is a low-severity missing authorization vulnerability in Gitlab Gitlab, published on 22 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-9957 exists.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 11.2.0; fixed in 18.9.6, 18.10.4, 18.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-9957/ (Markdown: https://insights.sbomify.com/CVE-2025-9957/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-9957
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-9957
- OSV: https://osv.dev/vulnerability/CVE-2025-9957

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-9957/
Summaries are generated and may contain mistakes; the official description above is the record.
